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1 Introduction
1.1 Description
ElementsXXL adds up to 230 powerful features to Photoshop Elements for Windows that were previously only available in
Photoshop. These features are available as new menu items, icons, key shortcuts and dialogs, so they seamlessly
integrate into the user interface of Photoshop Elements. ElementsXXL upgrades Photoshop Elements with features of
Photoshop and bridges the gap between Photoshop Elements and Photoshop.

Features

• Up to 230 new features for Photoshop Elements for Windows
• Actions, Scripts, Filters & Adjustment Layers:
♦ Open and run Photoshop actions and scripts (Elements 6 and higher)
♦ Up to ten new filters: Curves, Exposure, Vibrance, Color Balance, Channel Mixer, Black & White,
Selective Color, Sharpen, Sharpen More and Sharpen Edges.

♦ Up to seven new adjustment layers: Curves, Exposure, Vibrance, Color Balance, Channel Mixer, Black
& White and Selective Color.
♦ Shadows/Highlights filter dialog with seven new options
♦ Chromatic Aberration Removal filter for removing colored edges caused by lenses
♦ Color Match filter for applying the colors and brightness of another image

• Layer Features, Smart Objects & Smart Filtering:
♦ Many new features, e.g. three new icons, for the Layers panel
♦ Opens images as smart objects, creates smart objects and enables smart filtering
♦ Use layer groups for additional masking and better organization
♦ Create and edit vector masks
♦ Adjust the density and feathering of vector masks and shapes
♦ Create and work with layer masks (for Elements 1-8)
♦ Adjust the fill opacity of layers
♦ Align layers to a selection or each other and distribute them evenly
♦ Stamp visible function for creating a duplicated copy of all layers
♦ Hide/show multiple layers
• Enhanced 16-bit Image Processing:
♦ Process 16-bit images with the help of smart filters and layers (Elements 6 and higher, smart filter
rendering requires Elements 8 and higher)

♦ Convert images from 8-bit to 16-bit per channel and back again (Elements 6 and higher)
♦ Use up to 29 additional tools with 16-bit images (Elements 6 and higher)
♦ Quick Mask Mode lets you create or edit selections with all available filters and tools, e.g. the brush or
gradient tool. (Elements 6 and higher)

♦ Edit the channels of a RGB image individually and use them as selections
♦ New Curves, Channel Mixer and Sharpen filters
♦ Fade command for changing the blend mode and opacity of the last history step
♦ Apply Image command for blending two 16-bit images while using an image channel or selection as a
mask (Elements 11 and higher)

• General Editing:
♦ Up to 24 new key shortcuts known from Photoshop
♦ Five new tools: Pen, Puppet Warp, Mixer Brush, Ruler, Slice & Slice Select
♦ Auto-Align and Auto-Blend features for recomposing portraits, creating panoramas and increasing the
depth of macro shots (Elements 6 and higher)

♦ Edit the channels of a RGB image individually
♦ Fade and Trim commands like in Photoshop
♦ Apply Image command like in Photoshop (Elements 11 and higher)
♦ Soft proof option for seeing how your image looks on a certain device or printer
♦ Slice an image, add links and save it as a web page
♦ Paths panel for creating and editing paths
♦ Save Recovery Information feature for automatically saving all documents in certain time intervals and
reopening them after Photoshop Elements crashed

♦ New options: e.g. Non-Linear History, Log History to Metadata, Auto-Update All Documents
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♦ Custom pixel aspect ratio
• Selections:
♦ Color Range feature for creating selections based on colors and tones
♦ Quick Mask Mode for editing selections with filters and tools, e.g. the brush tool
♦ Transform selections (for Elements 1-7)
♦ Create selections from layer masks, layer opacity, luminosity and image channels
• Text Features:
♦ Larger Font Preview
♦ Three new text anti-aliasing types
♦ Spell check text layers and use Find & Replace on them
♦ Convert text layers to shapes for more creative freedom
♦ Adjust text tracking and use paragraph

2
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1.2 FAQ

Does ElementsXXL turn Photoshop Elements into Photoshop?
ElementsXXL adds many features to Photoshop Elements that are only available in Photoshop, e.g. running actions and
scripts, several new adjustment layers and filters, smart objects, smart filtering, layer groups, layer masks, channels,
vector masks, paths, 16-bit/channel conversion, quick mask mode and soft proofing. So ElementsXXL actually bridges a
large part of the gap between Photoshop Elements and Photoshop.
But there are a few limitations in Photoshop Elements that ElementsXXL cannot overcome (at least not in the latest
version): CMYK mode, video editing and 3D functionality. If you do not need them, you should be quite happy with
Photoshop Elements and ElementsXXL.

What is the difference between ElementsXXL and other products that extend Photoshop
Elements?
The big thing about ElementsXXL is that it fully integrates into the user interface of Photoshop Elements by adding new
menu items, key shortcuts, icons and various dialogs. ElementsXXL starts up together with Photoshop Elements, so it
does not need to be run manually. ElementsXXL feels like an upgrade to Photoshop Elements and not like a plugin or
external tool.
Other products that try to extend the functionality of Photoshop Elements have to be executed by clicking a button or
menu item. They are limited to a single dialog that blocks the user interface or consist of simple actions. So they are not
as intuitively and easy to use as ElementsXXL. They do not provide the rich features of ElementsXXL.
There is no other product that adds new Layers panel features, lets you run Photoshop actions and scripts directly, that
lets you apply smart filters from the Filter menu, offers support for so many smart filters, adds key shortcuts, offers Fade,
Color Range and Puppet Warp features, converts 8-bit images to 16-bit, allows processing 16-bit images with smart filters
and layers, offers 29 additional tools for retouching 16-bit images and lets you edit new types of adjustment layer.
ElementsXXL supports all available versions of Photoshop Elements and does not need to be purchased separately for
each Photoshop Elements version.

With which version of Photoshop Elements should I use ElementsXXL?
As ElementsXXL provides all of its almost all features in Photoshop Elements 11 to 13, we recommend using it with one
of these versions. See below for more details. ElementsXXL activates more than 200 features in Photoshop Elements 6 to
10, so best use ElementsXXL with at least Photoshop Elements 6. It would be even better to use at least Photoshop
Elements 8, because it can make use of ElementsXXL's Layers panel features. As ElementsXXL only adds 90-130 new
features to Photoshop Elements 1-5 better upgrade to a newer version of Photoshop Elements in order to get the most
out of ElementsXXL.

Are there any differences when using ElementsXXL in Photoshop Elements 11, 12 and 13?
There are a few differences. If you do not need to apply the Puppet Warp on 16-bit images and do not mind using a 32-bit
application, the best choice for ElementsXXL would be Photoshop Elements 11. If you can live with the small limitation of
Curves and require a 64-bit application, you should use Photoshop Elements 13.
Here is a detailed list of the differences:
Photoshop Elements 11:
- The Puppet Warp tool works only on images with 8-bit per channel.
+ The "Log History to Metadata" feature works.

ElementsXXL Manual

4

Photoshop Elements 12:
- The Puppet Warp tool is not available.
- The "Log History to Metadata" feature does not work.
Photoshop Elements 13:
+ The Puppet Warp tool works on images with 8-bit and 16-bit per channel.
- The "Log History to Metadata" feature does not work.
- The Auto and Option buttons on the Curves dialog do no work. Alternatively you can use the Auto commands at the top
of the Enhance menu, but you cannot edit their options.

How do I know which features are added by ElementsXXL and which are part of Photoshop
Elements?
ElementsXXL adds a blue background to its icons, buttons and menu items. To remove this colorization, please go to File
> Automation Tools > ElementsXXL and deactivate the "Colorize Icons & Menu Items" check box.
ElementsXXL also provides various new key shortcuts. You can see a list of its key shortcuts under File > Automation
Tools > ElementsXXL > Key Shortcuts. Additionally you can check out the manual on the menu under Help >
ElementsXXL Help. All features of ElementsXXL are mentioned and explained there in detail.

Where do I find the new features of version 2 of ElementsXXL in Photoshop Elements?
Here is a list of the new features in ElementsXXL 2 and where they are located:
Control bar: New render button menu (Photoshop Elements 11 and higher)
Tools bar: New tools icon at the bottom (Photoshop Elements 11 and higher)
Tools bar: If you activate certain tools for a 16-bit image, you will be asked for entering Tool Mode.
File > Save HTML (Saves a sliced document as a web page)
Edit > Fade (now includes support for 16-bit images and three new 16-bit blend modes)
Edit > Tools (five new tools)
Edit > New Slice
Edit > Slices from Guides
Edit > Preferences > Save recovery information
Edit > Preferences > Shortcuts (Three new key shortcuts)
Image > Mode > 16 Bits/Channel (New dialog with two new options)
Image > Render (Process 16-bit images with smart filters, layers and tools)
Image > Apply Image (New dialog for blending different images)
Enhance > Adjust Lighting > Shadows/Highlights (New dialog with seven more features)
Enhance > Adjust Color > Match Color (Applies the colors of another image)
Layer > Smart Filter > Clear Filter Mask
Layer > Smart Filter > Add Filter Mask
Layer > Vector Mask > Hide All
Layer > Vector Mask > Reveal All
Layer > Vector Mask > Current Path
Select > Color Range (Create selections based on colors and tones)
Select > Selection From > Vector Mask
Select > Selection From > Filter Mask
Filter > Add Smart Filters (New dialog of adding and editing smart filters)
Filter > Chromatic Aberration Removal
Bottom of Filter menu (Support for 260 third party smart filters)
View > Slice Numbers
View > Clear Slices
Window > Path (New Path panel for working with paths)
Some other new features work in the background and are not directly linked to a certain control or menu item.
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Does ElementsXXL 2 really allow using layers with 16-bit images in Photoshop Elements?
This question cannot be simply answered with a yes or no. ElementsXXL 2 offers so-called Render features, which
provide a workaround for the missing layer support for 16-bit images in Photoshop Elements. Adding and editing the
layers still takes place in 8-bit mode, but you can render a 16-bit image from all layers once you are through.
It works this way: You open a 16-bit image, convert it to a 8-bit document with embedded 16-bit image data and then start
adding layers and smart filters. You can save this 8-bit document and continue working later. Finally, you render all layers
of the 8-bit document to a 16-bit image. The 16-bit image contains no layers, just the flat end result. You can go back to
the 8-bit document with the layers, edit it again and recreate a 16-bit image from it any time.
You may ask if the resulting 16-bit image really contain true 16-bit depth or not. Well, it depends. Smart filters and
adjustment layers are rendered with true 16-bit precision. However, if there is a fully opaque layer that covers the whole
image, the rendered 16-bit image is degraded to 8-bit. To avoid that you can set the opacity of a layer to less than 100%,
use another blend mode than "Normal" or otherwise make the layer semi-transparent. Then the 8-bit and 16-bit data is
blended, which means that the 16-bit depth is retained. In some cases, e.g. by adding a text or using an opaque healing
brush on small image areas, it is neglectable that these small areas of the 16-bit image have an actual bit depth of 8-bit.
ElementsXXL provides a Check Bit Depth command on the Render menu, which calculates the actual bit depth of an
image. With its help you can make sure that the bit depth was not degraded.
As you can see the Render features require a few compromises, but they ultimately grant a much greater freedom when
processing 16-bit images.

I have a non-English version of Photoshop Elements. Can I use ElementsXXL with it?
Yes, definitely. 95% of the features of ElementsXXL are automatically translated to the language of Photoshop Elements.
For example, if you use a Spanish version of Photoshop Elements, all menu items and almost all dialogs of ElementsXXL
are in Spanish. Only the Preferences dialog and a few messages are only available in English and German.
There are only English and German manuals for ElementsXXL, but you can read about most ElementsXXL features in the
manual of Photoshop or on the Photoshop Help page - both of which are available for various languages. You can simply
search for a certain term, e.g. the name of a menu item, in the Photoshop PDF manual or on the Photoshop Help page.
Here are the Photoshop Help pages (where you can also find the Photoshop manual) in all languages that Photoshop
Elements supports: Czech, German, English, Spanish, French, Italian, Japanese, Dutch, Polish, Portuguese, Russian,
Swedish, Turkish, Chinese, Taiwanese.
Alternatively you can enter the term together with "Photoshop" in Google, e.g. "Photoshop Auto-Align Layers". Then you
will find a lot of information and tutorials about it.

Sometimes the Auto-Blend Layers feature of ElementsXXL does not work. What can I do about
it?
In some cases the Auto-Blend Layers feature may not have enough memory to perform its task. Here are some measures
to make it work anyway:
1. Exit all other applications.
2. Close all other documents in Photoshop Elements.
3. Choose Edit > Clear > All to free more memory in Photoshop Elements.
4. Go to Edit > Preferences > Performance and increase the Memory Usage to 90 or 95%.
5. Reduce the number of layers that are processed with Auto-Blend Layers.
6. Reduce the image size of the document that contains the layers.
7. If you run Windows 32-bit, upgrade to Windows 64-bit. This will double the amount of memory that Photoshop Elements
can use (from 1.6 GB to 3.2 GB RAM). In Photoshop Elements 13 (and higher) you can even use almost all of your RAM
under Windows 64-bit.
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Why is there no MacOS X version of ElementsXXL yet?
ElementsXXL does a lot of platform specific things, so making these features work on the Mac requires a lot of additional
work. So we want to make sure that there is enough interest before we start working on a Mac version of ElementsXXL.
The development of a Mac version depends on how the Windows sales develop and the number of requests for a Mac
version that we get. Only 20% of our customers are using a Mac, so when Windows sales and Mac requests reach a
certain level, we can be sure that there will be sufficient Mac sales to compensate for the invested time and money.
If you are interested in a MacOS X version, please let us know and spread the word about it. This will increase the
likelihood of an ElementsXXL version for MacOS X.
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1.3 Compatibility

ElementsXXL 2 works under Windows 8, 7, Vista, XP (32-bit & 64-bit).

It requires the following application to be installed:

• Adobe Photoshop Elements (Version 1 to 13)

All menu items and most dialogs of ElementsXXL are localized to the language of Photoshop Elements. The options of
the ElementsXXL Preferences dialog and some messages are displayed in English or German.

Feature/Version Table
Almost all features of ElementsXXL are available in Photoshop Elements 11 to 13. But there are a few subtle differences,
which are described in the FAQ. Otherwise, the lower the version of Photoshop Elements, the fewer features of
ElementsXXL are available.
Here is an overview of which features of ElementsXXL are available in which version of Photoshop Elements:

Photoshop Elements Version
Feature
Run Photoshop actions (4)
Run Photoshop scripts (2)

Black & White filter
Exposure filter
Vibrance filter
Curves filter *11
Channel Mixer filter
Color Balance filter
Selective Color filter
Sharpen filters (3)
Color Match filter NEW
Chromatic Aberration Removal filter
NEW
Black & White adjust. layer
Exposure adjustment layer
Vibrance adjustment layer
Curves adjustment layer *11
Channel Mixer adjust. layer
Color Balance adjust. layer

1

2

3

4

5

6

7

8

9

10

11

12

13
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Selective Color adjust. layer
Editing these adjustment layers *1
New Icons & Buttons NEW
New Key Shortcuts NEW

18

18

19

18

19

6

5

5

8

8

8

21

21

21

21

21

24

24

24

Native Smart Filters *4

95

95

103

103

103

101

100

100

Supported 3rd Party Smart Filters
NEW

262

262

262

262

262

262

262

262

25

25

25

25

28

29

29

29

Browse in Organizer
Convert to 16-bit/channel (2) NEW
Channels (8)
Fade *2
Auto-Align/Auto-Blend Layers (2)
Trim
Apply Image (2) NEW
Preference Options
(e.g. Large Font Preview) (6)
History Options (3) *10
Soft Proof (2)
Custom Pixel Aspect Ratio

Smart objects (6) *3
Smart filtering (12) NEW

Layer masks (8) *5
Vector masks (8) NEW
Shape / Vector Mask Properties (2)
NEW
Fill Opacity
Layer Groups (2)
Hide/Show Layers
Align Layers (6)
Distribute Layers (6)
Stamp Visible

16-bit Rendering (7) *6 NEW
Additional tools in 16-bit mode (Tool
Mode) *7 NEW
Pen Tool NEW
Puppet Warp NEW
Mixer Brush Tool NEW
Ruler Tool NEW
Slices (7) NEW
Color Range (11/1) *8 NEW
New Shad./High. Options (7) NEW
Paths panel (15) NEW
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Save Recovery Information NEW
Quick Mask Mode (2)
Transform Selection
Selection from masks, shape,
opacity, channels (8) NEW
New text anti-aliasing types (3)
Text Tracking
Paragraph Text
Spell check text layer *9
Find and Replace text
Convert text to shape
Total Number of Features

95

96

106

119

133

210

210

220

212

213

232

230

231

= works on images with 8-bit and 16-bit/channel (if applicable)
= works only on images with 8-bit/channel
= already built into Photoshop Elements
= not available
*1 = Photoshop Elements 1-7: To change the settings of an ElementsXXL adjustment layer you have to delete and add it
again.
*2 = Photoshop Elements 1-2: The Fade command does not work correctly with layers that contain transparent areas.
*3 = Photoshop Elements 5: Editing the contents of a smart object is not possible.
*4 = Photoshop Elements 6-7: The following dialogless filters do not work as smart filters: Find Edges, Solarisation, Facet,
Fragment, NTSC Colors, Sharpen, Sharpen More and Sharpen Edges.
*5 = Photoshop Elements 9-13: The layer mask feature "From Transparency" is added by ElementsXXL
*6 = Photoshop Elements 6-7: The rendering of smart filters to the 16-bit image does not work.
*7 = Photoshop Elements 6-10: Not all supported tools trigger Tool Mode. To trigger it anyway, select another tool and in
Tool Mode switch back to the old tool.
*8 = Photoshop Elements 1-4: Only the Sampled Color option of the Color Range feature works.
*9 = Spell checking does not work on all systems.
*10 = Photoshop Elements 12-13: The "Log History to Metadata" feature does not work
*11 = Photoshop Elements 13: The Auto and Option buttons on the Curves dialog do no work. Alternatively you can use
the Auto commands at the top of the Enhance menu, but you cannot edit their options.

Supported 3rd Party Smart Filters
In addition to the native Photoshop Elements filters ElementsXXL also supports 266 plugins from 26 plugin companies as
smart filters:

• AKVIS: AirBrush, ArtSuite, ArtWork, Chameleon, Coloriage, Decorator, Enhancer, HDR Factory, LightShop,
Make Up, Nature Art, Noise Buster, Refocus, Retoucher, Sketch, SmartMask

• Alienskin: Bokeh 1/2, Exposure 2-7, Eye Candy 5-7, Snap Art 1-4
• Amico Perry: Luce
• AV Bros: Page Curl 2, Page Curl Pro 2, Puzzle Pro 3
• Cybia: Alienator, Fluoron, HotShot, Retrograde, Vivida, BW-Plus, FastFix, G-Force, Hi-Spot, NightScope,

Pseudo-IR, SkyGrad, Techni-X, AlphaWorks, ColourWorks, EdgeWorks, EmbossWorks, MasterBlaster, Mezzy,
ScreenWorks, SwapShop
• Digital Film Tools: Film Stocks, Light 3.5, PhotoCopy, PowerStroke, Rays, reFine
• DxO Optics: FilmPack 3-5, ViewPoint
• ePaperPress: PTLens
• Filter Forge: Filter Forge 2/3
• Flaming Pear: Freebies, Aetherize, Boss Emboss, Flexify 2, Flood, Glare, Glitterato, Hue and Cry, India Ink,
Lacquer, LunarCell, Melancholytron, Mr. Contrast, Organic Edges, Silver, SolarCell, SuperBladePro, Swerve,
Twist, Vibrant Patterns, Wavy Color
• FocusMagic: FocusMagic 4
• HDR Soft: PhotoMatix Tone Mapping
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• Imagenomic: Noiseware, Portraiture, Realgrain
• Mediachance: Color! Color!, DCE Tools, ReDynamix
• namesuppressed: AutoInterlace Free, Softener 2
• Neat Image: Neat Image
• Nik Collection: Analog Efex Pro, Color Efex 4, Dfine 2, Sharpener Pro 3, Silver Efex Pro 2, Viveza 2
• Picture Code: Noise Ninja
• PowerRetouche: Anti-Aliasing, Black Definition, Black/White Studio, Brightness, Chromatic Aberration, Color

Corrector, Colorfringe Remover, Contrast, Dynamic Range Compressor, Edgeline, Equialize Luminance,
Exposure, Film Grain, Gamma, Golden Section, Graduated Color, Illumination Editor, Lens Corrector, Levels,
Noise Corrector, Posterize, Satuation, Sharpness, Soft-filter, Toned Photos, Transparency, Vignetting, White
Balance, Zone System
• Redfield: Bas-Relief, ATX, Craquelure 3D, Emblazer, Expressionist, Face Control 1/2, Fine Touch, Fractalius,
iEmboss, Jama 2000, Jama 3D, Lattice Composer, Lattice XP, Perfectum, Plasteroid, Ripples Magic, Seamless
Workshop, Sharpinion, Sharpinion HD, SketchMaster, Texturation 3D, Umatix, Water Ripples
• Red Giant: Knoll Light Factory, Magic Bullet PhotoLooks
• The Plugin Site: BWStyler 2, ColorStyler, ContrastMaster, FocalBlade 2, HyperTyle 2, NoiseControl,
PhotoFreebies, Plugin Galaxy 3
• Tiffen: Dfx 3
• Topaz Labs: Adjust, BW Effects, Clarity, Clean, DeJpeg, DeNoise, Detail 2/3, InFocus, Lens Effects, ReStyle,
Simplify, Star Effects
• Van Der Lee: Halftone
• Xycod: Postworkshop 3
If you want ElementsXXL to support other plugins as smart filters, please let us know. Please note that some plugins (e.g.
AutoFX, OnOne, FilterForge 4) do not support smart filtering.
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1.4 Installation

Uninstallation
If you want to install the full version or a newer version, you normally do not need to uninstall the trial version or older
version. The trial or old version is overwritten when installing the full or newer version - provided that you chose the same
installation location for both and activated the same application(s) in Plugin Installer. If you are unsure, you can
nevertheless uninstall the trial or old version before installing the full or newer version.
To uninstall ElementsXXL go to Start > All Programs > The Plugin Site > ElementsXXL > Uninstall ElementsXXL and
follow the instructions.

Installing
Double click the downloaded .exe file and follow the installation instructions. When Plugin Installer shows up, activate the
check boxes of your preferred application(s) and press the Install button.

You can run Plugin Installer at any time from Start > All Programs > The Plugin Site > ElementsXXL > Plugin
Installer. Then you have more options than during installation, e.g. an Uninstall button.
If you install a new version of Photoshop Elements and ElementsXXL is already installed, you do not need to run the full
ElementsXXL installation again. You can run Plugin Installer from the Start menu and use it to install ElementsXXL into
the newly installed version of Photoshop Elements.
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1.5 Step by Step

1.5.1 Running a Script
1. Open an image in Photoshop Elements.
2. Choose a script from the File > Scripts sub menu or from the Scripts button on the control bar.
3. If the script displays an error message, it is probably not possible to run it in the current version of Photoshop Elements.
If you have some JavaScript programming knowledge, you can try to edit the script file, e.g. in Notepad, and fix the
problem.

1.5.2 Running an Action
1. Open an image in Photoshop Elements.
2. If no actions are loaded, choose Load Actions from File > Actions or from the Actions button on the control bar. For
example, you can find the action files of Photoshop Elements 11 at C:\ProgramData\Adobe\Photoshop
Elements\11.0\Photo Creations\photo effects\.
3. Choose an action from the File > Actions sub menu or from the Actions button on the control bar.
4. If the action displays a message that a certain command is not available, click the Continue button to run the action
nevertheless.

1.5.3 Fading the Last Editing Step
1. Open an image in Photoshop Elements and carry out an image editing step, e.g. apply a filter from the Filter menu.

2. Choose Fade from the Edit menu.
3. Change the opacity and/or the blend mode and click OK.
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1.5.4 Combining Multiple Portrait Photos
1. Open at least two images in Photoshop Elements and copy them as layers into one document.
2. Select these layers in the Layers panel.

3. Choose Auto Align Layers from the Image menu.
4. In most cases you will be fine with the default options, otherwise adjust them. Finally click OK.
5. Create a layer mask for each layer and use the brush tool for making certain image areas of a layer visible or invisible.
This way you can combine the best parts of each photo.

1.5.5 Combining Panorama Photos
1. Open at least two images in Photoshop Elements.
2. Copy them as layers into one document.
3. Choose Image > Resize > Canvas size. Enter 200% for width if you have two images, 300% if you have three images
and so on.
4. Use the Move tool to position the images next to each other. Make sure that the image layers overlap each other
where they have the same image content.
5. Select these layers in the Layers panel.
6. Choose Auto Blend Layers from the Image menu.

8. Select Panorama from the Blend Method options. If desired, activate the check box for seamless tones and colors.
Finally press OK.
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9. Use the Crop tool to crop away the superfluous borders of the images.

1.5.6 Combining Macro Photos
1. Open at least two images in Photoshop Elements and copy them as layers in one document.
2. Select all layers in the Layers panel.
6. Choose Auto Blend Layers from the Image menu.

4. Select Stack Images from the Blend Method options. If desired, activate the check box for seamless tones and colors.
Finally press OK.

1.5.7 Editing Image Channels Individually
1. Open an RGB image in Photoshop Elements.
2. From the Image > Channels sub menu choose the desired channel or channel combination.
3. If you want to see all channels while editing only one or two of them, select Image > Channels > Show All.
4. Now perform your image editing operation, e.g. applying a filter. It will only be applied to the selected channel(s).
5. To select all three channels again, choose Image > Channels > RGB or switch to another layer in the Layers panel.

1.5.8 Using Smart Objects
1. If you want to store the whole image file into a smart object, please use the File > Open as Smart Object menu
command. Otherwise open the image with File > Open.
2. If you did not open the image with File > Open as Smart Object and want to convert one or more of the layers into a
smart object, do the following: Select the appropriate layers in the Layers panel and choose Layer > Smart Object >
Convert to Smart Object. Alternatively you can click the smart object icon on the Layers panel.
3. If you want, you can now change the name of the smart object and adjust its opacity and blend mode in the Layers
panel.
4. You can losslessly rotate and transform the image by using the Rotate, Transform and Resize sub menus of the
Image menu. You can also use the Crop and Trim items on the image menu as well as the move tool. The embedded
contents of the smart object are left untouched by these operations.
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5. You can also add a layer mask to the smart object with Layer > Layer Mask > Reveal All (or click the layer mask icon
on the Layers panel). Now you can edit the layer mask with tools and filters.
6. To edit the contents of the smart object, choose Layer > Smart Object > Edit Contents or double click the thumbnail of
the smart object in the Layers panel.
6a. A new document with the contents of the smart object opens up. You can now edit the smart object
document.
6b. After editing choose File > Save to update the smart object in the original document.
6c. Close the smart object document and return back to the original document.

1.5.9 Applying and Editing Smart Filters
1. After creating a smart object as described above, choose a filter from the Filter menu. Alternatively you can choose
Filter > Add Smart Filter, which automatically creates a smart object, and then double click one of the filters on this dialog.
2. The filter dialog appears where you can edit the settings of the filter. Press OK.
3. In the case of a native filter the blending dialog appears. There you can edit the blend mode and opacity of the filter.
Press OK.
4. If you want, you can apply another smart filter from the Filter menu.
5. After applying a smart filter, the filter mask (one mask for all smart filters of a smart object) is automatically selected.
Otherwise you can select it from Layer > Smart Filter > Select Filter Mask or by reselecting the smart object in the Layers
panel.
5a. To edit the filter mask use a tool. For example, you can use the brush tool to remove the filter effect
from certain image areas.
5b. To disable, enable or clear the filter mask use the appropriate options from the Layer > Smart Filter
menu.
6. To edit the applied smart filter(s), choose the filter from the top of the Layer > Smart Filter menu. For more editing
options choose Layer > Smart Filter > Edit Smart Filters or click the smart filter symbol in the Layers panel.

6a. In the Edit Smart Filter dialog select a filter in the list and click one of the buttons to either edit the
filter settings or the filter blending, to enable or disable the filter or to delete it.
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6b. To apply all changes that you performed with this dialog click the OK button. To remove all changes
click Cancel.

1.5.10 Processing 16-bit Images with Smart Filters, Layers and Tools
1. Open an image with 16 bits per channel in Photoshop Elements.
2. Choose "Prepare 8-bit Document" from the Image > Render sub menu or the Render button menu of the option bar in
Photoshop 11 and higher. This converts the current 16-bit document into a special 8-bit document that has the 16-bit data
embedded.

3. If you want to apply a filter, choose the Add Smart Filter command from the Render menu. In the displayed dialog you
will only see filters that also work with 16-bit images. This is indicated by the "(16-bit)" suffix on the Add tab sheet. Double
click a filter to apply it. If you switch to the Edit tab sheet you can edit the applied smart filters. Leave this dialog with the
OK button. If you want, you can now you use the brush tool, gradient tool or other tools to restrict the effect of the smart
filters to certain image areas.

4. If you want to apply an adjustment layer, use the Add Adjustment Layer command. Double click an item from the list to
apply it. When you have finished click the OK button. The added adjustment layers are displayed in the Layers panel
where you can also edit their layer mask. Please do not manually add other adjustment layers, because they will not be
rendered to the final 16-bit image. You can add fill layers though.
5. To selectively brighten and darken certain image areas choose the Add Dodge/Burn Layer command from the Render
menu. The dodge tool is automatically activated and you can start using it on the image to brighten up certain details. To
darken image areas switch to the burn tool. You can also use the brush - best with reduced opacity - on the dodge/burn
layer if you like. To undo changes it is best to use the brush tool with a mid gray color. You can also use the eraser tool,
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but we advice against it.
5. If you want to use a tool, activate the Add Tool Layer command. Now select your tool and start using it on the image.
Some tools only work if a "Sample All Layers" or a "All Layers" check box is activated on the tool options bar. If you want,
you can later adjust the blend mode and opacity of the tool layer on the Layers panel as well as add a layer mask to it.
6. You can also add other types of layers to the document. For example, you can add a text layer, shape layer or a fill
layer.
7. Save the document as a PSD file in order to edit it later and render new 16-bit images from it.
8. Choose "Render 16-bit Document" from the Image > Render sub menu (or the Render button menu). As a result a new
16-bit document is created and the previous image operations (the layers and smart filters) will be rendered to it.

1.5.11 Using Layer Groups
1. Select one or more layers in the Layers panel.

2. Click the layer group icon or choose Layer > Group Layers. This creates a new layer group from the selected layers.

3. If you want, you can rename the group by double clicking its name, e.g. Group 1, in the Layers panel. Change the
opacity and blend mode of the layer group if needed.
4. You can also add a mask to the layer group by clicking the layer mask icon or choosing Layer > Layer Mask > Reveal
All.
5. To edit the layers of the layer group again click the layer group icon once more or choose Layer > Ungroup Layers.
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6. If the layer group has a mask, you will be asked if you want to store it. Click Yes.
7. Edit the ungrouped layers.
8. To restore the layer group again, select all of its layers in the Layers Panel and click the layer group icon or choose
Layer > Group Layers.

9. On the appearing dialog click the Yes button to restore the name, blend mode, opacity and mask of the old layer group.

1.5.12 Using a Layer Mask
1. If there is only the background image displayed in the Layers panel, double click it to turn it into a layer.
2. To use a selection for creating a layer mask, create the selection and choose Layer > Layer Mask > Reveal Selection
or click the layer mask icon on the Layers Panel. If you do not want to use the selection for the layer mask, choose Layer
> Layer Mask > Reveal All or delete the selection and click the layer mask icon on the Layers Panel. Now you can see the
layer mask in the Layers panel.

3. To edit the layer mask apply a filter or tool. The Select > Refine Edges command is also quite useful for modifying a
layer mask.

1.5.13 Using a Vector Mask
1. If there is only the background image displayed in the Layers panel, double click it to turn it into a layer.

ElementsXXL Manual

20

2. You can now either draw a shape with the shape tool, create a selection with the lasso or marquee tool or create a
path with the Text on Path tool (in Photoshop 10 and higher only). This selection, shape or path will be converted into a
vector mask.
3. Depending on whether you created a selection, shape or path choose either From Selection, From Shape or Current
Path from the Layer > Vector Mask sub menu. Now you can see the vector mask in the Layers panel.

4. You can now use the move tool or the shape selection tool to move, rotate and scale the vector mask. You can also
use the Rotate and Transform sub menus of the Image menu to transform the vector mask.
5. To apply filters and other tools to it, you can convert the vector mask into a normal layer mask by choosing Layer >
Vector Mask > Rasterize.
5a. To convert the layer mask back to a vector mask, choose Select > Selection From > Layer Mask,
then Layer > Layer Mask > Delete and finally Layer > Vector Mask > From Selection.

1.5.14 Using Quick Mask Mode
1. It is often useful to start by creating a rough selection, e.g. with the lasso or marquee tool. In Photoshop Elements 4 &
5 this is even required, otherwise Quick Mask Mode will not work.

2. Choose Select > Edit in Quick Mask Mode or in Photoshop Elements 11 (or higher) click on the Quick Mask icon at the
bottom of the tool bar. If the current image is in 16-bit/channel mode, a new document called "Quick Mask Mode" is
opened, which allows bypassing the 16-bit limitations of Photoshop Elements.

3. Now you will see the whole image (if no selection was created in step 1) or the unselected image areas (if a selection
was available) colored red. This indicates that the selection was transformed into a mask.
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4. If you want to change the mask properties choose Select > Quick Mask options. Usually you do not need them.

5. Use the available filters and tools to edit the mask. Select white as the foreground color at the bottom of the tool bar for
extending the mask e.g. with the brush tool. A black foreground color lets you remove image areas from the mask.

6. When you are satisfied, choose Select > Edit in Quick Mask Mode again. Alternatively, click on the Quick Mask icon at
the bottom of the tool bar in Photoshop Elements 11 (or higher).

7. The mask was converted back to a selection and you can now apply filters and tools to the refined selection.

1.5.15 Proofing Colors
1. Choose Proof Color from the View menu.

2. Choose an item from the Device to Simulate combo box.
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3. If you have some color management knowledge, you can also deactivate the Preserve RGB Numbers check box and
change the other options.
4. Click OK. The image is now displayed as it would look on the chosen device.
5. If you notice a color problem, fix it by using a color filter or another tool.
6. To restore the normal view of the image, choose View > Proof Colors again and click OK without changing a setting.

1.5.16 Creating a Web Page
1. Create a new document or open an image that you want to use as the background for the web page.
2. Use the text tool to insert the main text or text for buttons. You can add content on multiple layers if you want.
3. After you have finished designing and editing the web page, you can begin marking various areas of the the document
that should be clickable hyperlinks. Start by activating the slice tool from Edit > Tools > Slice Tool or by using the icon
menu at the bottom of the tool bar in Photoshop Elements 11 and higher.
4. With the slice tool draw a rectangle over an area that you want turn into a hyperlink. Such an area is called a user slice.
While creating a user slice, Photoshop Elements automatically splits up other image areas into so-called auto slices.
Alternatively to produce a slice, you can also create a selection and choose Edit > New Slice. Placing guides and
selecting Edit > Slices From Guides is yet another method to slice up the document.

5. To link a slice to an URL or html file, right click on the slice and choose Edit Slice Options from the context menu. On
the Slice Options dialog enter a html file or http web address in the URL field and click OK.

6. To select another already existing slice hold down the Ctrl key and click on it. You can edit its size by dragging the
handles of the slice rectangle. To remove all slices and start again, choose View > Clear Slices. If you activate the Slice
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slices visible.
7. Save the whole document including the slices as a PSD file, so that you can edit it later.
8. Choose File > Save HTML to save the web page as an html file plus a sub folder of image files.
9. Now you can design additional pages in the same manner and link to them from the main web page that you already
created.
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2 Menu Items
2.1 File Menu
ElementsXXL adds three menu items and two sub menus to the File menu of Photoshop Elements.

2.1.1 Browse in Organizer
Supported by Photoshop Elements 4 and higher
Requirements: None
This item in the File menu basically provides the same functionality as the organizer icon in the lower left part of the
Photoshop Elements window. It makes it easier to activate the organizer instantly. Moreover, it is equivalent to the
"Browse in Bridge" menu item in Photoshop.

2.1.2 Open as Smart Object
Supported by Photoshop Elements 5 and higher
Requirements: None
This feature displays a file dialog for opening an image. But unlike the normal Open command it automatically embeds
the opened image document (including its layers) into a smart object. For more information on smart objects, please see
the Convert to Smart Object item of the Layer Menu.

2.1.3 Save HTML
Supported by Photoshop Elements 4 and higher
Requirements: An image has to be opened and at least one slice should be created.
The Save HTML command works like the Save For Web menu item if no slice is available. If you created at least one slice
(see the Slice Tool), it produces a .html file and saves the document as multiple image files. The Slices features let you
turn a Photoshop Elements document into a web page and the Save HTML menu item saves this web page.

2.1.4 Scripts
Supported by Photoshop Elements 6 and higher
Requirements: Depend on the script
The Scripts sub menu lets you run script files that carry out various operations in Photoshop Elements. Scripts can be
edited in a text editor. They are highly adaptable, provided that you have some programmer skills. Scripts are either
delivered with Photoshop Elements as well as other Adobe applications or can be downloaded from various web sites.
Please note that not all available scripts are compatible with Photoshop Elements, so you may experience an error
message and some scripts may not work.
The Scripts sub menu can also be accessed by clicking the Scripts button on the control bar in the upper left part of the
window.
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Browse
The Browse menu item displays a file dialog for choosing a script file. After choosing it the script file is automatically
executed.

Scripts Menu Items
The script menu displays scripts from up to two different folders. Click on these scripts to run them.
If you previously opened a script with the Browse menu item, then the scripts that are located in the same folder are
displayed at the top of the Scripts sub menu. Below a separation line appear scripts from the Scripts folder of Photoshop
Elements, which are located in the Presets sub folder of the Photoshop Elements folder.

2.1.5 Actions
Supported by Photoshop Elements 6 and higher
Requirements: Depend on the action, usually an image has to be opened
The Action sub menu lets you run action files that carry out various operations in Photoshop Elements. Actions are either
delivered with Photoshop Elements as well as Photoshop or can be downloaded from various web sites. Actions can be
recorded in Photoshop, but not in Photoshop Elements. In Photoshop Elements 11 and 12 you are also able to access
actions from the Actions panel.
There are some .atn action files in the Required sub folder of the Photoshop Elements folder as well as at
c:\ProgramData\Adobe\Photoshop Elements\12.0\Photo Creations\photo effects\. If you are using an older version,
replace "12.0"in this file path with your version number of Photoshop Elements. You can load these actions with the Load
Actions command.
Some action may display a message that a certain command is not available. By clicking the Continue button you can
nevertheless run the action, which will result in success in many cases.
The Actions sub menu can also be accessed by clicking the Actions button on the control bar in the upper left part of the
window.

Load Actions
The "Load Actions" menu item displays a file dialog for choosing an action file. After choosing it, the actions of the action
file are displayed on the Actions sub menu.

Clear Actions
The "Clear Actions" menu item deletes all actions displayed on the Actions sub menu in case you already opened too
many actions. This will make your workflow more neat if you want new actions displayed at the top of the Actions menu.

Reset Actions
The "Reset Actions" menu item restores or appends the default actions. A message box will ask you about replacing the
current actions. Click Yes to clear all action and load only the default ones. Click No to append the default actions to the
existing action or click Cancel to abort the operation.

Actions Menu Items
The Actions menu provides actions which are loaded in Photoshop Elements. Clicking on one of these actions runs them.
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2.2 Edit Menu

ElementsXXL adds four menu items to the Edit Menu of Photoshop Elements, including an item for changing the
ElementsXXL preferences.

2.2.1 Fade
Supported by all versions of Photoshop Elements
Requirements: An image adjustment or effect should be applied before using it.
The Fade command lets you adjust the opacity and blend mode of the last operation, respectively the last item shown in
the History panel. So make sure that the last history item is an operation that changes the image pixels, otherwise Fade
will have no effect.

Fade saves you the work of undoing the last image editing step, creating a new layer, reapplying the image editing,
adjusting the opacity and blend mode of the new layer and merging the new layer with the old one.
If you work with an image with 16 bits per channel, there will be three more blend modes available. The Subtract and
Divide blend modes are known from Photoshop CS5 and higher. The Exposure blend mode is unique (not available in
Photoshop) and can be used to transform blur effects into sharpening and contrast enhancement effects. To convert an
image to 16 bits per channel use the Image > Mode > 16 Bits / Channel command.

2.2.2 Spell Check
Supported by Photoshop Elements 2-9 & 11-13
Requirements: A text layer has to be selected in the Layer panel.
The Spell Check menu item checks the spelling of the currently selected layer or that of all layers if the Check All Layers
check box is activated.
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This feature does not work with all Photoshop Elements versions and not all systems. Sometimes only a "Spell Check
Complete" message appears. So far it is unclear why it works on some computers and not on others, but it may help if
Photoshop is also installed on your computer.

2.2.3 Find and Replace Text
Supported by by all versions of Photoshop Elements
Requirements: A text layer has to be selected in the Layer panel.
With the Find and Replace Text item you can find certain letters or words in a text layer and exchange them by others. It
works similar as you know it from text editing programs.

In the Find What text box above you insert the text that you want to exchange. In the Change To text box below you
insert the text that is to replace the search term of the Find What text box. The "Find Next" button selects the first found
word. Clicking it again highlights the next occurrence. The Change button replaces the search term accordingly. Change
All replaces all occurrences of the search terms. Change/Find executes both actions, changing and finding, but requires
to firstly click Find Next at first. Done exits the dialog.
If the Search All Layers check box is activated, all text layers are searched. A deactivated Forward check box searches
the text backwards. An activated Case Sensitive check box makes sure that the case of the letter of the search term is
not ignored. Whole Word Only treats the search term like a single word and not as multiple ones. For example, the term
"of the" would not be separately found as"of" and "the" words but only as combined "of the" text blocks.

2.2.4 Tools
Requirements: An image needs to be opened.
The Tools sub menu supplies several new tools that are otherwise not accessible. You can also display this menu by
clicking on the right icon at the bottom of the tool bar in Photoshop Elements 11 and 12.

Pen Tool
Supported by Photoshop Elements 10 and higher
This command actually activates the Text on Path tool, which can also be used for creating and editing paths as well as
modifying shapes and vector masks, which actually consist of paths. Normally when switching to another tool Photoshop
Elements automatically deletes the created path. ElementsXXL suppresses this behavior. For deleting a path please use
the Path panel.
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On the Tool Options bar you see Draw and Modify icons. By default the Draw icon is active, so if you want to edit the
created path, you have to click the Modify icons. The dots that the path consists of will appear then and you can drag
them to modify the path. To delete a path dot hold down the Alt key and click on it. To reposition a path activate the Draw
icon, hold down the Ctrl key, click on the path line and drag.
There is also a Pen Tool button on the Path panel. We recommend that you display the Path panel, because it provides
several other useful features when working with paths.

Puppet Warp Tool
Supported by Photoshop Elements 11 and 13
The Puppet Warp Tool works with images up to 6000 x 6000 pixel. If the image is larger, the areas outside the 6000 x
6000 pixels can not be targeted with it. When activating this tool, a web-like grid is placed over the image. Firstly you have
to click somewhere to set a pin point, otherwise the image will be moved if you hold down the mouse button and move the
mouse. Then you can click and drag to distort a certain image area. When finished hit the Enter key or click the
checkmark icon on the Tool Options bar. Clicking the checkmark icon on the image does not work.
Each click sets a new pin point that can be dragged. Unfortunately the pin points are not indicated clearly in Photoshop
Elements (other than in Photoshop). You can only hunt them down by watching your cursor, which changes when you
move over one of them.

On the Tool Options bar you have various controls for changing the behavior of the Puppet Warp tool in order to undo all
pins and complete or abort the operation.

Mixer Brush Tool
Supported by Photoshop Elements 10 and higher
The Mixer Brush simulates painting techniques, e.g. mixing colors on the canvas, combining colors on a brush, and
varying paint wetness across a stroke. You can sample an image area by holding down the Alt key and clicking on the
image. The sampled area can be seen on the Tool Options bar.

On the Tool Options bar you can choose a brush tip and switch between various options which influence the brush
drawing.

Ruler Tool
Supported by Photoshop Elements 4 and higher
The Ruler Tool lets you draw a line on the image and read out its coordinates, length and angle on the Tool Options bar.
The ruler line can also be repositioned and its ending points can be modified. Press the Clear button on the Tool Options
bar to delete the line.

Slice & Slice Select Tool
Supported by Photoshop Elements 4 and higher
The Slice tool lets you draw rectangles on the image, so-called slices, for defining areas as HTML tables. These tables
and their related image tiles can later be exported to a html file with the File > Save HTML menu command. You can turn
slices into buttons and then connect these buttons to another html file or web address. Every slice you create (so-called
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user slices) automatically produces other slices (so-called auto slices) that cover the entire image outside the user slice.
The created slice is displayed as a rectangular frame. You can change the slice dimensions by dragging its handles and
reposition it by clicking on it and dragging. If multiple slices exist, you can select another slice by holding down the Ctrl key
and clicking on it.

If you right click a slice, you will see a context menu with additional options. The Edit Slice Options menu item displays a
dialog where you can enter an URL or html file that is loaded when later clicking on it in the web browser.
The Slice Select Tool lets you switch between slices by clicking on them. You can also create new slices with the Slice
Select Tool if you hold down the Ctrl key. So you do not need to switch to the Slice tool in order to do that. To select
multiple slices hold down the Shift key when clicking on them. With multiple slices selected you can align the slices with
the icons on the Tool Options bar.
To remove all slices choose View > Clear Slices from the menu.

Restore Tools
Supported by Photoshop Elements 4 and higher
When activating the Mixer brush, Ruler, Slice and Slice Select Tools it is not possible to activate the brush, color picker
and crop tools on the tool bar (unless you press the B, I and C keys). The Restore Tools command makes the brush, color
picker and crop tools again visible on the tool bar.

2.2.5 New Slice
Supported by Photoshop Elements 6 and higher
Requirements: A selection is required
The New Slice command creates a new slice from a selection. If the selection is not rectangular, the imaginary rectangle
that encloses the selection will be used for the new slice. The Slices features let you turn a Photoshop Elements
document into a web page. For more information see the Slice Tool above.

2.2.6 Slices From Guides
Supported by Photoshop Elements 6 and higher
Requirements: At least one guide needs to be present
You can choose this menu item to create slices that are defined by lines of guides that were added beforehand. The
Slices features let you turn a Photoshop Elements document into a web page. For more information see see the Slice
Tool above.
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2.2.7 Preferences > ElementsXXL
Supported by Photoshop Elements 6 and higher (except as stated below)
Requirements: None
If you click on this menu item on the Preferences sub menu, a dialog window is opened that lets you change the settings
of Elements XXL. You can switch between different preferences groups by using the list on the right or by clicking the
Prev and Next buttons. To set all options to the original default values click the Reset button. Press OK to apply the
changes on this dialog or Cancel to discard them.

ElementsXXL Page

The Deactivate ElementsXXL check box lets you deactivate ElementsXXL without installing it. You have to restart
Photoshop Elements to make the deactivation work. To reactivate ElementsXXL again please choose File > Automation
Tools > ElementsXXL from the menu. This option works in all versions of Photoshop Elements.
When running ElementsXXL for the first time, all menu items, icons and buttons of ElementsXXL have a blue background,
so that you immediately see which features were added. To retain this highlighting activate the Colorize Icons & Menu
Items check box. Once you know ElementsXXL well enough, you can deactivate it again. This option works in Photoshop
Elements 4 and higher.
If you are using a non-English version of Photoshop Elements and would like to see the menu items and dialogs of
ElementsXXL in English language, you can activate the Force English Localization check box. You have to restart
Photoshop Elements for this feature to start or stop working. This feature can be helpful if you want to look up certain
things in the English manual or if the localization to your language does not work perfectly.
If you experience a crash after exiting Photoshop Elements, you can use the Alternative Shutdown check box to avoid it.
Please do not activate this check box if this problem does not occur, otherwise you may risk that Photoshop Elements
really crashes on exit.
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General Page

If the Auto-Update Open Documents check box is activated, Photoshop Elements constantly checks whether the
currently opened documents were updated on the hard drive or on a network location. If the file of one of the documents
was modified by another software or the operating system, the file will automatically be loaded and appears as a new item
in the History panel. So even if the file is automatically updated, you do not lose your current editing work in Photoshop,
because you can undo the automatic update if you want.
The Large Font Preview check box displays the font samples on the font combo box larger than usual. This makes it
much easier to identify the look of the fonts. This option works in Photoshop Elements 1 to 12.
Here you can see the Tool Options panel with the large font preview on the left and the original, smaller font size on the
right:

The Interpolation check box lets you adjust the interpolation that is used for the move tool and functions from the Image
menu, e.g. Free Rotate Layer, Free Transform, Skew, Distort, Perspective and Scale.
The Save recovery information combo box allows you to automatically save all open documents to a temporary folder in
a certain time interval. When the documents are saved for recovery, you can see a small progress window in the top left
corner of the Photoshop Elements main window. If you have a lot of documents or very big documents opened, the saving
process can take some time and you have to wait. The recovery information is deleted if Photoshop Elements exits
without crashing. If Photoshop Elements crashes and is run again, a message will ask you if you want to recover the
documents that were lost during the crash.
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Once the recovered documents are opened, you should save them to their original location again. Additionally when you
exit Photoshop Elements you are also asked if you want to discard the recovery information. If you do not confirm it, you
will be asked to recover again the next time you run Photoshop Elements.
Finally, there is a check box called Show classic Shadows/Highlights dialog. Activating this check box displays the
standard dialog of the Shadows/Highlights filter and not the own Shadows/Highlights dialog of ElementsXXL. Even if you
do keep this check box deactivated, you can use the classic dialog by clicking the Classic button on ElementsXXL's
Shadows/Highlights dialog.

History Page

The Auto-Create First Snapshot check box is activated by default and displays a snapshot item in the History panel
when an image is opened. Deactivate it to avoid the snapshot item.
When you undo steps and apply a new operation, the undone steps vanish from the History panel. By activating the
Non-Linear History check box you avoid that they vanish when you apply a new operation. Now you can still switch back
to these unused history states.
The Log History to Metadata check box adds all steps of the History panel to the metadata of the image, which is saved
together with the image data to a file. Now you can see which editing steps where applied to an image by using the File >
File Info menu command and switching to the History tab sheet on the appearing window. This option only works in
Photoshop Elements 4-11.
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Key Shortcuts Page

The Deactivate Key Shortcuts check box deactivates (and activates again) the key shortcuts of ElementsXXL. All
available key shortcuts are shown in the list below. This feature works in all versions of Photoshop Elements.
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2.3 Image Menu

ElementsXXL adds five menu items and two sub menus to the Image menu of Photoshop Elements.

2.3.1 Auto-Align Layers
Supported by Photoshop Elements 6 and higher
Requirements: At least two layers have to be selected in the Layers panel.
The Auto-Align Layers function lets you align two or more very similar photos in order to combine them to one image. This
is quite useful if you want to combine multiple shots of the same subject, e.g. a group of people, or photos taken with
different exposure or depth of field.
Firstly, you need to place each photo on a different layer. Then you select all layers in the Layers panel and run the
Auto-Align Layers command. After the layers were aligned, you can use layer masks to only add the best parts of each
layer to the final image.

In the Auto-Align Layers dialog you can choose between different options for making the projection of the images identical
as well as performing automatic lens corrections.
The Auto option automatically performs the best projection for the corresponding image layers. If you select any of the
other choices, only this item will be observed by the alignment process. An activated Vignette Removal Check box as
well as Geometric Distort performs the corresponding tasks.

2.3.2 Auto-Blend Layers
Supported by Photoshop Elements 6 and higher
Requirements: At least two layers have to be selected in the Layer panel.
The Auto-Blend Layers function enables you to put different images together in order to create either a panoramic scenery
with seamless transitions or stack images one above the other in order to increase the depth of field of macro photos.
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The Auto-Blend Layers dialog offers two blend methods to select. An activated checkbox grants smooth transitions and
colors.

2.3.3 Trim
Supported by all versions of Photoshop Elements
Requirements: The image has to contain a colored frame or a layer with transparent pixels.
The Trim menu item allows you to cut away the colored or transparent areas at the borders of the image. This is useful if
you scanned a photo and want to remove extraneous areas.

The Trim dialog box lets you select three options that the trimming is based on. You can either trim away transparent
pixels on a layer or pixels of a certain color. The color can be picked up from the top left or bottom right corner. The four
check boxes determine, where the empty areas are to be trimmed.

2.3.4 Mode > 16 Bits/Channel
Supported by Photoshop Elements 6 and higher
Requirements: An image with 8-bits per channel.
Normally Photoshop Elements only supports converting images with 16-bit to 8-bit per channel. ElementsXXL adds this
feature to the Mode sub menu to let you convert 8-bit to 16-bit images. Please note that Photoshop Elements does not
support layers for 16-bit images, so all layers will be flattened when doing this conversion. The selection is retained by the
conversion.
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After triggering this command you will see a dialog with two options. The Open New Document check box opens a new
window when converting the image to 16 bits per channel and retains the original 8-bit document with all layers and
history states. Otherwise you lose them. The Preserve Meta Data check box makes sure that the meta data are
transferred to the new 16-bit document. This usually means that the conversion will be slower when doing it for the first
time.

2.3.5 Channels
Supported by all versions of Photoshop Elements
Requirements: The image has to be in RGB mode.
Each image consists of three color channels: Red, Green and Blue. The Channels sub menu lets you view and edit the
different color channels according to your preferences. Once having selected a certain channel, you can apply all tools
and filters to it.

RGB
The RGB menu item, which is the default setting, selects and displays all three color channels.

Red, Green, Blue, Red + Green, Red + Blue, Green + Blue
These menu items let you view and select the different color channels and channel combinations. If you want to edit all
three channels again, please choose the RGB item.

Show All
This menu item shows all channels, even if only one or two of them are selected. If you want to edit all three channels
again, please choose the RGB item.

2.3.6 Render
Supported by Photoshop Elements 6 and higher, but rendering of smart filters requires Photoshop Elements 8 and higher
Requirements: Requires a 16-bit image
The Render commands enable you to process an image with 16 bits per channel with the help of smart filters, adjustment
layers and other layer types. Photoshop Elements does not support smart filters and layers for 16-bit images, but
ElementsXXL makes it possible by working in 8-bit mode and later rendering the special 8-bit document to a 16-bit image.
There is also a Render menu button on the control bar in Photoshop Elements 8 and higher for accessing all Render
commands quickly.
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Prepare 8-bit Document

The original 16-bit document

The prepared 8-bit document with embedded
16-bit data

The Prepare 8-bit Document command converts a 16-bit image into a 8-bit document with embedded 16-bit data. The
Background layer of the 16-bit document is converted into two layers: one with the 8-bit image data (bits 1 to 8) and one
with the remaining bits (bits 9 to 16). Both new layers are called "Base Image" and "Base Image (16-bit data)" and will
later be used to recreate the original 16-bit image. So do not rename or delete these layers, otherwise rendering to 16-bit
will not work. You can save the prepared document in PSD or TIFF format and render it to 16-bit at a later time.
After your prepared the document you can add smart filters, adjustment layers and other types of layers to it. We
recommend that you use the other menu items for adding smart filters and adjustment layers, because not all of them
support 16-bit images, so they will not applied when rendering to 16-bit. The Add Smart Filter and Add Adjustment Layer
menu items make sure that you only use supported ones.
Add Smart Filter

The Add Smart Filter command is only available in Photoshop Elements 8 and higher. It displays a dialog that lists all
smart filters that also support 16-bit images. Smart filters that can only be applied to 8-bit images are not displayed here.
The left list box shows the filter groups, which you know as sub menus from the menu bar. The All group contains all
available filters in the right list box whereas the other groups only display their own filters.
To apply a smart filter double click it in the right list box or select it and click the Add button. As a result the filter dialog
appears. In the case of the native filters a second Blending dialog follows. For third party plugins you can adjust the
blending on the Edit tab sheet.
After adding smart filters you can immediately edit them again by clicking on the Edit tab button at the top. For more
information on editing smart filters see the Layer Menu page.
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When you are finished, click the OK button in the bottom right corner. Cancel will undo all addition and edits.

Add Adjustment Layer

The Add Adjustment Layer dialog lets you apply all adjustment layers that are supported for 16-bit rendering. Double click
a list item or select one and click the Add button to apply it. As a result the dialog of the adjustment layer will appear. After
you applied all adjustment layers click the OK button.
You can edit the adjustment layers any time by double clicking their thumbnail in the Layer panel. You can also edit their
blend mode, opacity and layer mask there.
Adjustment layers are not listed on this dialog (Brightness/Contrast, Gradient Map, Photo Filter, Exposure, Vibrance,
Color Balance, Black & White, Selective Color) are ignored and not rendered to the 16-bit image. So better not add them.
If you need such an effect, try to find a smart filter that does something similar. Color fill, gradient fill and pattern fill
adjustment layers are supported, but only applied as rasterized image data and not rendered via filters to the 16-bit
image.

Add Dodge/Burn Layer
This menu item creates a special type of layer that is meant for dodge and burn operations with the dodge and burn tools.
When choosing this menu item the dodge tool is automatically activated. You can switch to the burn tool on the Tool
Options bar or by pressing the O key. Now brush over the image to selectively brighten or darken certain image areas.
You can also add a layer mask to this layer or change its blending mode to Soft Light or Hard Light for softer or hard
effects. To vary the intensity of the effect either change the layer opacity or adjust the Exposure slider on the Tool Options
bar.
When rendering the 16-bit document, the dodge/burn layer is blended with the 16-bit image. Although the layer itself is
8-bit, the blending makes sure that the result is still 16-bit.

Add Tool Layer
The Add Tool Layer command simply adds an empty layer and displays some instructions. Alternatively you can also
create such a layer by clicking on the New Layer icon of the Layers panel or use the Layer > New > Layer menu
command.
You can use various tools on this empty layer. In some cases you have to activate the Sample All Layers check box on
the Tool Options bar. Here is a list of tool that can be used:

• Spot Healing Brush (requires activated Sample All Layers check box)
• Healing Brush (requires activated Sample All Layers check box)
• Clone Stamp (requires activated Sample All Layers check box)
• Pattern Stamp
• Blur (requires activated Sample All Layers check box)
• Sharpen (requires activated Sample All Layers check box)
• Smudge (requires activated Sample All Layers check box)
• Brush
• Impressionist Brush
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• Eraser
• Background Eraser
• Magic Eraser
• Paint Bucket
• Gradient
• Pencil
It is a good idea to create more than one tool layer if you use multiple tools.
When the document is rendered to 16-bit, tool layers usually add 8-bit data to the 16-bit image. Only if the layer opacity or
tool opacity is less than 100% and the blending mode is not Normal, then 8-bit data is blended and results in true 16-bit
image data. If the image data on a tool layer is fully opaque, it is added with 8-bit depth to the rendered 16-bit image.

Adding other layers
Apart from the options of the Render menu you can also add other types of layers to the document. For example, you can
add a text layer with the text tool, a shape layer with the shape tool and add a layer with the smart brush tool.

Check Bit Depth
The Check Bit Depth command displays the number of tonal values and bits per channel that an image contains. If you
apply this command to an 16-bit image, you can investigate if it contains true 16-bit data or not. 8.
If the "Actual bits/channel" value is 12.0 or higher, you can be sure that the image is a true 16-bit image. If the displayed
value is below 12.0, the image may have been upsampled from 8-bit and probably does not contain true 16-bit data. If the
value is 8.0 or lower, you can be 100% sure that the image was upsampled. Please note that the maximum displayed
values are 32768 and 15.0, because Photoshop and Photoshop Elements always cut off the 16th bit for performance
reasons.
You can also make use of this function after rendering the 16-bit image. This way you can be sure, that the bit depth was
not impaired by the rendering.

Render 16-bit Document
The Render 16-bit Document command produces a 16-bit image from the prepared 8-bit document. Supported
adjustment layers and smart filters are rendered with 16-bit precision whereas other layers may add 8-bit data if they are
fully opaque and use a Normal blend mode. For example, a text or shape layer means no problem, but opaque areas that
were covered e.g. by the healing brush or clone stamp may loose their 16-bit depth. To avoid that you could set the layer
opacity to 90 or 95%.
Please note: In Photoshop Elements 6 and 7 rendering smart filters to a 16-bit image is not possible. So please do not
add them to the prepared 8-bit document.
When triggering the Render 16-bit Document command ElementsXXL creates a new 16-bit document, recreates the
original 16-bit images and applies the smart filters and layers of the 8-bit document to it. At first it applies the smart filters,
then it starts with the lowest layer above the two Base Image layers and works its way up to the top layer. A progress
window is displayed in the top left corner, which indicates which layer is currently processed and the percentage of the
completed work.
Rendering the 16-bit document can take several seconds depending on how big the image is and how smart filters and
layers have to be applied. The result is a new 16-bit document with one background layer. In the History panel you can
see which filters and operations were applied to it to reproduce the look of the 8-bit document.

2.3.7 Apply Image
Supported by Photoshop Elements 11 and higher
Requirements: An image needs to be opened. For blending two images you need to open two images with the same
dimensions and mode.
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The Apply Image menu item is aimed at the blending of two layers or images and enables the user to easily produce
collage and layer effects. It applies the channels and selections of a source layer or a merged copy of all layers to the
target layer with the help of certain blending and masking settings. The target layer is the layer that is selected in the
Layers panel.

If at least two image with the same dimensions and image mode are opened in Photoshop Elements, the Select Source
Document dialog will appear. Here you can choose another document as the source for the actual blending operation. If
you keep "Current Document" selected here, you will only be able to combine the layers of the active document. After
clicking OK the main Apply Image dialog appears.

To carry out the Apply Image feature choose a source layer from the Source combo box, a channel from the Layer
option and a selection, which was previously saved with the Select > Save Selection command. An activated Invert
check box inverts the selection.
You can then define the blend mode, opacity and mask that will be used when applying the source image. When the
Mask check box is activated, you can see more options for selecting a certain layer, channel and saved selection, which
will then be used as a mask. Additionally the Preserve Transparency check box keeps the transparency of the target
layer untouched.
With a bit of experimentation you will get a better feel for the controls.
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2.4 Enhance Menu

ElementsXXL adds 11 menu items to the Enhance Menu of Photoshop Elements.

2.4.1 Adjust Lighting > Shadows/Highlights
Supported by Photoshop Elements 3 and higher
Requirements: An image needs to be opened.

The Shadows/Highlights filter enables you to adjust the brightness of the darkest and brightest areas of an image
independently. ElementsXXL lets you run this filter with the new Ctrl + H key shortcut and replaces the standard
Shadows/Highlights dialog with its own dialog. The new dialog looks similar to the old one until you activate the Show
More Options check box at the bottom. Then you get all the features that Photoshop's Shadows/Highlights filter offers.

41
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With Show More Options activated, you receive three sliders instead of one for correcting the shadows as well as
highlights. And you get three more adjustment options.
The Lighten Shadows and Darken Highlights sliders of the unexpanded dialog are now called Amount. The Tonal
Width sliders define the range of tonal values that will be affected. At the lowest value only the darkest or brightest areas
of the image will be changed. Higher slider values also include the midtones.
The Radius sliders determine the softness of the transition between the adjusted areas and the rest of the image. A low
Radius value makes the adjustment look flat and creates harsh transitions. On the other hand a too high Radius may
weaken the adjustment, because the transition areas can replace the adjusted areas.
The Color Correction slider basically adjusts the saturation of the image. Strong corrections may increase or decrease
the saturation, so this slider lets you handle such problems. The Black Clip and White Clip text boxes are for entering a
percentage value that influences how many tonal values are cut off at both ends of the tonal scale. These two options are
similar to the black and white slider knobs of the Levels filter. A higher Black Clip value, e.g. 5.0%, usually produces
stronger shadows. But increasing the White Clip value can quickly remove details from the brightest image areas, so it
should be handled with more care.
If you hold down the Alt key, the Cancel button is renamed to Reset and you can click on it to recreate the default settings
for all controls. To switch to the standard Shadows/Highlights dialog of Photoshop Elements click on the Classic button in
the bottom right corner. To get the classical dialog from the start, activate the check box Show classic
Shadows/Highlights dialog under Edit >Preferences > ElementsXXL > General.

2.4.2 Adjust Lighting > Curves
Supported by Photoshop Elements 1-3, 5 and higher
Requirements: An image needs to be opened.
The Curves filter lets you change and improve the brightness and contrast of digital images by remapping the brightness
values of the image. By default the "curve" is displayed as a diagonal line in the diagram, which means that the input and
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output values are the same and no adjustment is applied.
The curve can be adjusted with the help of points. To create a new point click somewhere in the diagram and drag. After
releasing the mouse button a curve is drawn through the new point. You can adjust your point or add new points until you
get the desired result. You can also adjust curve points by entering numbers in the Input and Output boxes. Alternatively
draw your individual curve with the Pen tool and click the Smooth button to improve it. The Auto button automatically
corrects the brightness, contrast and color of the image according to the settings displayed by the Options button.
The curve in the following screenshot shows a typical contrast adjustment with the help of an S curve consisting of three
added points:

There are eye dropper tools for picking a black and white point (the darkest and brightest pixels) from the preview.
Additionally the gray eye dropper performs a color correction when you click on a slightly colorized gray area in the
preview. The hand tool lets you create and adjust a curve point by clicking and dragging on the preview. The Show
Clipping check box visualizes image areas where the tonal values are cut off.
The screenshot below shows a typical curve for increasing brightness:
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When clicking on the double arrow button at the bottom, more controls show up: Light is the default setting whereas
Pigment/Ink simply inverts the values of both axes of the diagram, which makes the colors run from white to black and
rotates the curve by 180 degrees. The two diagram icons change the number of lines in the diagram. The Channel
Overlays check box shows the adjustments that were done with the three eyedropper tools. The Baseline check box
removes or adds the diagonal line in the diagram. The Intersection Line check box displays crossing lines when you
move a curve point. The Histogram check box only shows a clearly visible histogram in Photoshop Elements 6 to 10. In
Photoshop Elements 11 and 12 the histogram is almost invisible.

2.4.3 Adjust Lighting > Exposure
Supported by Photoshop Elements 6 and higher
Requirements: An image needs to be opened.
The Exposure filter changes the brightness of the image with three different methods. It is easier to use, but offers less
control than the Curve filter.

The Exposure slider adjusts the brightness of the image similar to the photographic exposure. The Offset slider moves
the brightness values into a certain direction without taking shadow or highlight rescue measures. The Gamma
Correction slider applies a brightness correction that is known from computer monitors and is similar to the middle slider
of the Levels adjustment.
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Again you have three eyedroppers for picking a black, gray and white point. They directly adjust the value of the Exposure
or Offset slider.

2.4.4 Adjust Color > Channel Mixer
Supported by Photoshop Elements 1-3, 5 and higher
Requirements: An image needs to be opened.
The Channel Mixer recomposes each color channel of an RGB image by blending the three RGB channels according to
certain percentage values, which produces color effects. Additionally if the Monochrome check box is activated, you are
able to create a black & white effect that is defined by a mix of the three color channels.

The Output Channel combo box selects the color channel that is affected by the four sliders. Each output channel option
owns different slider values, so there are actually 12 slider values in total. The Red, Green and Blue sliders define the
color mix that is used for the selected output channel. As long as the Total value of all three sliders is 100%, the
brightness of the image is not affected. The Constant slider adjusts the brightness of the current output channel. To reset
all values hold down the Alt key and click on the Cancel button, which is now named Reset.

2.4.5 Adjust Color > Vibrance
Supported by Photoshop Elements 8 and higher
Requirements: An image needs to be opened.
The Vibrance filter changes the saturation of the image. Whereas the Saturation slider produces a more or less standard
saturation adjustment, the Vibrance slider additionally protects skin tones from getting too saturated.
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2.4.6 Adjust Color > Color Balance
Supported by Photoshop Elements 1-3, 11 and higher
Requirements: An image needs to be opened.
The Color Balance filter allows you to adjust the color of shadow, midtone and highlight areas separately.

To select a certain tonal range click either the Shadows, Midtones or Highlights radio button. Each of these options
allows different values for the three color sliders. The Preserve Luminosity check box keeps the brightness of the image
unchanged while it is colorized.

2.4.7 Adjust Color > Selective Color
Supported by Photoshop Elements 1-3, 11 and higher
Requirements: An image needs to be opened.
The Selective Color filter lets you independently adjust certain color and gray areas of the image. It is similar to the Adjust
Hue/Saturation filter, but uses the CMYK color model instead of the HSL one, as you can see from the names of the
sliders. Additionally it also allows adjusting white, neutral and black areas. On the other hand the adjustments of the
Selective Color filter are less precise, because there is no feature for editing the color ranges.

Select the target color from the Colors combo box and use the sliders to change it. Each combo box option uses
different slider values, so there are a total of 9 * 4 = 36 slider values. The two Method radio buttons at the bottom switch
between different color adjustment methods. To reset all values hold down the Alt key and click on the Cancel button,
which is now named Reset.
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2.4.8 Adjust Color > Match Color
Supported by Photoshop Elements 3 and higher
Requirements: Two 8-bit images need to be opened.

The Match Color filter lets you grab colors from another image and apply them to the current one in order to equalize the
color mood of both images. This way you can make sure that two images have the same overall color. The image from
which the color are grabbed is defined by the Source combo box. There you can select any other document that was
opened in Photoshop Elements.
There are two effects selectable from the Mode combo box. The Global Light effect takes the average color of the other
image to uniformly colorize the current image. The Local Range effect grabs colors from various areas of the other image
thus colorizing the current image differently in various places. The Desaturate check box makes sure that the current
image is only adjusted in brightness and not color.
The Intensity slider controls the saturation of the color effect. The Radius slider determines the size of the areas from
which colors are grabbed by the local effect.

2.4.9 Black & White
Supported by Photoshop Elements 6 and higher
Requirements: An image needs to be opened.
Similar to the Monochrome option of the Channel Mixer filter, the Black & White filter turns a color image into a grayscaled
one. With six instead of three sliders for adjusting the black & white effect, you have more control, but it also gets more
complicated. Additionally you can colorize the black & white image with the help of a color box and two color sliders.
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The six top sliders define the black & white effect of the filter by mixing six different color channels, which are based on
the RGB and CMY color models. To colorize the black and white effect activate the Tint check box. Now you can click on
the color box to choose another color from a color dialog or use the Hue and Saturation sliders to adjust the color. The
Auto button tries to find a balanced black & white mix by evaluating the image.

2.4.10 Sharpen, Sharpen More, Sharpen Edges
Supported by all versions of Photoshop Elements
Requirements: An image needs to be opened.
These three simple sharpening filters apply the effect without showing a dialog. Sharpen More applies a stronger
sharpening than the Sharpen filter. Sharpen Edges only sharpens the edges in the images. To reduce the effect of these
filters either apply them to a layer and adjust their opacity or use the Edit > Fade command.
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2.5 Layer Menu

ElementsXXL adds 5 new sub menus and up to 47 menu items on 8 sub menus to the Layer Menu of Photoshop
Elements.

2.5.1 Smart Filter
Supported by Photoshop Elements 6 and higher (with a few limitations in Photoshop Elements 6-7)
Requirements: A smart object with an applied smart filter must be selected in the Layers panel
Smart filters allow readjusting their filter settings after they have been applied, so they make non-destructive image editing
possible. On the other hand they can only be applied to smart objects. Read more about smart objects below.
The Smart Filter sub menu lets you edit the smart filters of a smart object. It is only accessible if at least one smart filter is
applied to a smart object. In Photoshop Elements 6 and 7 it is already accessible if a smart object without a smart filter is
selected in order to avoid a delayed display of this sub menu. To apply a smart filter to a smart object use the Filter menu.

Menu Items at the Top
The names of the smart filters that are applied to the current smart object are displayed at the top of this menu (except in
Photoshop Elements 6 and 7). By clicking the name of one of the filters, its dialog and blending options are displayed. So
this is a fast way to change the settings of a smart filter.
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Edit Smart Filters
The Edit Smart Filters dialog allows you to change the settings, blend mode and opacity of each smart filter that is applied
to a smart object. Additionally you can enable, disable or delete each smart filter. You can experiment freely here,
because you can undo everything again by pressing the Cancel button.

After selecting the smart filter that you want to edit from the list, you can use one of the four buttons at the right hand side.
The Edit button displays the filter dialog for editing its settings again. The Blending button shows a dialog for adjusting
the blend mode and opacity of the smart filter. En-/Disable disables an activated smart filter and enables a deactivated
one. If a filter in the list has a minus sign in front of its name, it means that it is disabled. A plus sign indicates that the filter
is enabled. The Delete button removes the selected smart filter. The Up and Down buttons move the selected smart filter
up or down in the list thus changing the order in which the filters are applied. To apply the changes press OK. Cancel
undoes all changes performed with this dialog.
In Photoshop 6 and 7 you will not see the names of the smart filters, but "Filter 1", "Filter 2" and so on. This is because the
smart filter names are not accessible in those versions.

Enable/Disable Smart Filters
This item disables or enables all smart filters of a smart object.

Clear Smart Filters
This item deletes all smart filters of a smart object.

Select Filter Mask
This item selects the filter mask. The filter mask is similar to a layer mask, but it only masks the effects of the smart filters.
Normally the filter mask is automatically selected after adding a smart filter or selecting the smart object in the Layers
panel. But in case it was deselected by another operation, you can use this menu command to select it again. The filter
mask can be modified with a tool or a filter.

Disable/Enable Filter Mask
This item disables or enables the filter mask. If the filter mask is disabled, the effects of the smart filters are not masked
anymore. If you did not modify the filter mask, these menu commands will make no difference.
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Add Filter Mask
This item creates a new filter mask from the current selection. The old filter mask is lost. To create a selection from the
filter mask see the Select > Select From > Filter Mask menu command.

Clear Filter Mask
This item erases the content of the filter mask. The effects of the smart filter will then be applied to the whole image again.

2.5.2 New Adjustment Layer
Curves, Color Balance, Channel Mixer, Selective Color: Supported by Photoshop Elements 1-3, 11 and higher
Exposure, Black & White: Supported by Photoshop Elements 6 and higher
Vibrance: Supported by Photoshop Elements 8 and higher
Requirements: An 8-bit/channel image needs to be opened.
ElementsXXL adds up to seven additional adjustment layers to the New Adjustment Layer sub menu: Curves, Exposure,
Vibrance, Black & White, Color Balance, Channel Mixer and Selective Color. The dialog is identical to the filter
version of these adjustment layers, so please read the Enhance Menu page for more information.
Filters are only applied to one layer whereas adjustment layers affect all layers underneath them. Except, if they have a
clipping mask activated, they affect only the layer right below them.
Similar to smart filters the settings of adjustment layers can be readjusted in Photoshop Elements 8 and higher. To do that
please double click the thumbnail of the adjustment layer in the Layers panel. In Photoshop Elements 1-7 you have to
delete the adjustment layer and create it again to change its settings.

2.5.3 Type
Supported by all versions of Photoshop Elements
Requirements: A text layer has to be selected in the Layers panel.
ElementsXXL adds several new features to the Type sub menu for influencing text layers.

Convert to Shape
This command converts a text layer to a shape layer. Text that was converted to a shape offers some creative freedom
that is not possible with text layers. On the image below the Shape Selection tool was used to resize, rotate and
reposition each letter individually.

On the other hand once you converted a text layer to a shape, you cannot change the text contents anymore. To have a
backup better duplicate the text layer before converting it to a shape.
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Anti-Alias Off / Crisp / Sharp / Strong / Smooth
ElementsXXL adds three new text anti-aliasing methods. Anti-Alias Crisp replaces the original Anti-Alias On menu item,
so it produces the same effect. The Sharp, Strong and Smooth methods produce a different degree of anti-aliasing,
which makes the text look either sharper or smoother than the default Crisp setting.

Convert to Paragraph/Point Text
By default a text layer is set to point text, which means that the text area will expand when you enter more text. If you
convert it to paragraph text, the text area will stay constant and not expand or shrink when changing the text. This is
useful if you want to constrain a text layer to a certain area in an image.

Tracking
The Tracking dialog lets you adjust the distance between each letter of a text. Set the tracking to zero to have the default
distance.

2.5.4 Smart Object
Supported by Photoshop Elements 5 and higher
Requirements: An image needs to be opened.
A smart object is a special kind of layer that contains a document that is kept untouched. Thus a smart object can contain
multiple layers and other information. All operations are applied to a flattened copy of the embedded document. Smart
objects guarantee a non-destructive editing of image data as well as the use of smart filters.

Convert to Smart Object
This feature converts all selected layers into a single smart object. To embed a full image document you can also use the
Open as Smart Object menu item from the File menu.

New Smart Object via Copy
The "New Smart Object via Copy" menu item simply duplicates a smart object. You can also use the normal Duplicate
Layer command instead.
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Edit Contents
The Edit Contents feature can also be triggered by double clicking the thumbnail of a smart object in the Layers panel.
If a raw file is embedded in the smart object, the Edit Contents command lets you readjust the Camera Raw settings of
the raw file. When the Adobe Camera Raw dialog shows up, edit the settings and click the Open Image button to apply
the changes.
If the smart object has no raw file embedded, the Edit Contents command opens the document that is embedded in the
smart object for editing. To commit the changes to the smart object in the original document choose File > Save or press
Ctrl + S. If the smart object has smart filters applied to it, these filters are then rendered again.
If the smart object was created in Photoshop, the smart object will very likely have a .psb document embedded. As
Photoshop Elements does not recognize this file extension, please do the following to make the smart object editable:
1. Use the Export Contents command (see below) to save the embedded .psb file,
2. Rename the file extension of this file from .psb to .psd.
3. Use the Replace Contents command (see below) to embed the .psd file into the smart object.
4. Try the Edit Contents command again.

Export Contents
If you want to save the contents of a smart object as a file, you can use this command. If the smart object was created in
Photoshop, it is likely that it will be saved as a .psb file. Photoshop Elements does not support this file extension, so
please rename its file extension to .psd to be able to open it again.

Replace Contents
Replace Contents enables you to replace the document that is embedded in the smart object while keeping the settings of
the smart object including its smart filter untouched. Make sure that the new document has the same image size as the
current one, otherwise it will be resized.

2.5.5 Group Layers
Supported by Photoshop Elements 4 and higher
Requirements: One or more layers have to be selected.
The Group Layers command embeds the selected layer(s) into a layer group, which is displayed with a folder symbol in
the Layers panel. Layer groups let you organize layers better and give you a better overview if you use a lot of layers.
Another advantage of layer groups is that you can apply the same blend mode and opacity to all layers in a group. Even
more, you can add a group mask in addition to the layer masks that each of the included layers may already have.
You can also click on the layer group icon on the Layers panel to group (and ungroup again) the selected layers.
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Left: Multiple layers were selected for inclusion in a layer group. Right: The resulting layer group.

Unfortunately once the layers are included in a layer group they cannot be edited anymore (which is still possible in
Photoshop) unless you ungroup them again. ElementsXXL lets you store the properties of the last layer group (including
its mask) when ungrouping it, to avoid losing them. See the Ungroup Layers section below for more information.
If the properties of an old layer group were saved, you will see the following message when trying to create a new layer
group:

If you want to restore the properties of the old layer group, click "Yes". If you want to create a totally new layer group, click
"No". In this case the properties of the old layer group will be lost. If you want to avoid that, click Cancel and recreate the
old layer group before creating a second, totally new layer group.
A new layer group is set to "Pass Through" blend mode by default, which means that it affects all layers below it. If you do
not want that, simply change the blend mode of the layer group to "Normal". Actually, doing this (including a layer in the
layer group and setting the blend mode of the layer group "Normal") is also a workaround for the limitation in Photoshop
Elements of not being able to use clipping masks together with layer groups.

2.5.6 Ungroup Layers
Supported by Photoshop Elements 4 and higher
Requirements: A layer group has to be selected.
If you want to edit the layers included in a layer group, you have to ungroup them with this command. You can also use
the layer group icon on the Layers panel.
Ungrouping a layer group would normally mean that its properties are lost. If the layer group has no mask, then its name,
blend mode and opacity are stored automatically - provided you edited one of them. When creating a new layer group,
you will be asked if you want to recreate the properties of the old layer group (as shown above).
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If the group has a mask when ungrouping it, the above message will appear. Click Yes to store the mask and other
properties of the layer group. Doing so will give you the option of restoring them again with the Group Layers menu
command (see above). The main reason for this message is that the group mask is stored as a channel, which increases
the document size. So you have the choice not to store it if you do not want to recreate a layer group.

2.5.7 Hide/Show Layers
Supported by all versions of Photoshop Elements
Requirements: One or more layers have to be selected.
Normally you can only make single layers invisible or visible by clicking the eye symbol in the Layers panel. With the help
of this menu item you can hide or show multiple layers that are selected in the Layers panel.

2.5.8 Layer Mask
Supported by Photoshop Elements 1-8 (already built into Photoshop Elements 9 and higher, except the "From
Transparency" command)
Requirements: One or more layers have to be selected.
Each layer can have a layer mask. A layer mask defines which areas of a layer are visible (opaque), partially visible
(transparent) or invisible (fully transparent). Layer masks are basically grayscaled images and can be edited like them.
White areas in the layer mask indicate full opacity whereas black area represent fully transparent areas. Gray mask areas
mean partial transparency. Dark gray mask areas are more transparent that bright gray ones.

Layer masks are displayed as black & white thumbnails at the right hand side of the image thumbnail in the Layers panel.
You can click their thumbnail to select them (which displays a colored frame around them) and start editing them instead
of the layer image. You can modify a layer mask with all available tools and filters. To edit the layer image again click the
image thumbnail.

Reveal All
The Reveal All menu item creates a mask and makes the whole layer opaque.

Hide All
The Hide All menu item creates a mask and makes the whole layer fully transparent.
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Reveal Selection
If a selection is available, this menu command creates a new layer mask and draws the selection into the layer mask. The
previously selected areas will be white (meaning opaque) in the newly created layer mask and the non-selected areas will
be black (fully transparent).

Hide Selection
If a selection is available, it creates a new layer mask and copies an inverted version of the selection into it. The
previously selected areas will be black (fully transparent) in the newly created layer mask and the non-selected areas will
be white (opaque).

From Transparency
The From Transparency command uses the transparency information of a layer (the so-called alpha channel) when
creating a layer mask. The transparent layer areas will be black in the layer mask.

Delete
Removes the layer mask. The transparency effect of the layer mask will be lost.

Apply
Adds the layer mask to the transparency information of the layer (the so-called alpha channel) and removes the layer
mask. The transparency effect stays the same, even without the layer mask.

Enable/Disable
Activates or deactivates the layer mask without removing it. You can do the same by holding down the Shift key and
clicking on the vector mask thumbnail in the Layers panel.

Link/Unlink
If the layer mask is linked to its layer, it will be repositioned together with the layer. If both are unlinked, the layer mask
does not move with the layer. Sometimes it is necessary to reposition the image content of a layer while keeping its layer
mask at the same position. That is what this command is for. You can do the same by clicking the chain symbol, which is
located between the two thumbnails of a layer item in the Layers panel.

2.5.9 Vector Mask
Supported by all versions of Photoshop Elements (except Properties dialog)
Requirements: A layer has to be selected in the Layers panel.
A vector mask is similar to a layer mask, but consists of vector graphics instead of normal image data. It also controls the
transparency of a layer. A vector mask is resolution independent and can easily be scaled and transformed with the
Shape Selection tool without getting pixelated. The downside is that you can only edit it with the shape tools and the
commands from the Rotate and Transform sub menus of the Image menu. You can edit shapes with these menu
commands as well, because shapes are actually solid color adjustment layers with a vector mask.
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Vector masks are displayed as thumbnails at the right hand side of the image thumbnail in the Layers panel.
Reveal All
The Reveal All menu item creates an empty vector mask that makes the whole layer opaque. To reveal only a part of the
layer go to the Edit > Tools > Pen Tool and draw on the image.

Hide All
The Hide All menu item creates an empty vector mask that makes the layer fully transparent. To reveal a part of the layer
again go to the Edit > Tools > Pen Tool and draw on the image.

Current Path
This item applies the currently selected path as a vector mask. For information about creating a path see Edit > Tools >
Pen Tool.

From Selection
Uses a selection to create the vector mask. The selected areas will also be visible and opaque whereas the other areas
will be fully transparent.

From Shape
After creating a shape with the shape tool you can use this feature to create the vector mask from the shape. The shape
area will be visible and opaque whereas the other areas will be fully transparent in the vector mask. The shape layer is
removed when adding it as a vector mask to the layer underneath.

Properties
Supported by Photoshop Elements 8 and higher

This command displays the Properties dialog for adjusting the density and feathering of vector masks as well as shapes.
The density slider controls the transparency of the areas that are not covered by the vector mask or shape. The feather
slider softens the edges of the vector mask or shape.
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Delete
Removes the vector mask.

Rasterize
Transforms the vector mask into a normal layer mask, which is more flexible for certain tasks, but is resolution dependent.

Disable/Enable
Activates or deactivates the vector mask without removing it. You can do the same by holding down the Shift key and
clicking on the vector mask thumbnail in the Layers panel.

2.5.10 Align (Layers to Selection)
Supported by all versions of Photoshop Elements
Requirements: Either a selection has to be available or at least two layers have to be selected in the Layers panel
If a selection is present, the Align commands align a certain border of the selected layer(s) to the selection. If no selection
is available, they align the bottom layer(s) to a certain border of the top layer. The items of this sub menu determine the
border to which the layers are aligned.
You can find the same commands as icons on the tool options bar of the move tool.

2.5.11 Distribute
Supported by all versions of Photoshop Elements
Requirements: At least three layers have to be selected in the Layers panel
The Distribute commands distribute three or more layers equally by making sure that the same amount of space is
between each layer. You can select in which direction the equal distribution is performed by choosing one of the items of
this sub menu.
This feature works best with transparent image layers, which do not contain image data across the full width or height of
the document. Otherwise there is no room for distributing the different layers.
You can find the same commands as icons on the tool options bar of the move tool.

2.5.12 Stamp Visible
Supported by Photoshop Elements 4 and higher
Requirements: An image has to be opened
The Stamp Visible command adds a flattened version of all layers as a new layer on top of all layers. This is very useful if
you want to apply a filter to the whole image while keeping all layers. It is an alternative to the Flatten Image command,
which removes all layers.
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2.6 Select Menu

ElementsXXL adds four new menu items and one sub menu to the Select menu of Photoshop Elements that make it
easier to work with selections.

2.6.1 Color Range
Supported by all versions of Photoshop Elements
Requirements: An image has to be opened.
The Color Range dialog lets you create a selection based on a sampled color or certain color and brightness ranges.

The method for creating a selection can be chosen from the Select Combo box. The Sample Colors method uses the
foreground color, which is displayed at the bottom of the tool panel, to produce the selection. Click on the image to choose
another color. To reduce or enlarge the selection area use the Fuzziness slider.
The following options only work in Photoshop Elements 5 and higher: The Reds to Magentas options select image areas
with certain color ranges whereas the Highlights to Shadows options select image areas with a certain brightness level.
The Skin Tones option selects areas that have a similar color as the human skin, which is useful for portrait retouching.
Selection marquees do not visualize semi-transparent areas sufficiently. That is why the Color Range dialog offers a
Selection Preview combo box, which allows displaying the produced selection differently. The default Selection option
shows a regular marching ant selection marquee whereas the Grayscale option displays it as a grayscale image, which
makes clear which areas are mid gray and thus semi-transparent. Black Mate and White Mate cover the unselected
areas with black or white color whereas the Quick Mask option covers them with red color.
To invert the selection use the Invert check box. When you have finished click OK or abort with the Cancel button.

2.6.2 Transform Selection
Supported by Photoshop Elements 1-7 (already built into Photoshop Elements 8 and higher)
Requirements: A selection is required. The image has to be 8-bit per channel.
After choosing this menu item a frame is displayed around the selection in the image. You can use the frame handles to
move, resize and rotate the selection. Once finished, click the check mark icon at the bottom to apply the changes to the
selection. The second icon cancels the changes.
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2.6.3 Edit in Quick Mask Mode
Supported by all versions of Photoshop Elements for 8-bit/channel images and Photoshop Elements 6 and higher for
16-bit/channel images
Requirements: In Photoshop Elements 4-5 a selection is required. In Photoshop Elements 1-3 a selection is
recommended.
This menu item activates and deactivates the Quick Mask Mode. In Quick Mask Mode a selection is transformed into a
mask, which is visualized by a red color overlay. This mask can be edited like an image with all available tools and filters.
Even selections can be used to modify the mask.

1. After drawing a selection with the Lasso tool.

2. After switching to Quick Mask Mode.

3. With the brush tool the outlines of the object
were masked precisely.

4. After exiting Quick Mask Mode. The mask was
converted back to a selection.
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When you have finished with editing the mask, you can convert it back to a selection by clicking the "Edit in Quick Mask
Mode" menu item again.
When using the Quick Mask Mode feature on a 16-bit/channel image, a new document called "Quick Mask Mode" is
opened. This allows you to use all tools and filters on the mask. When ending Quick Mask Mode, the edited mask is
transferred to the original document.

2.6.4 Quick Mask Options
Supported by all versions of Photoshop Elements
Requirements: "Edit in Quick Mask Mode" has to be activated beforehand
After the Edit in Quick Mask Mode menu item was activated, you can adjust the appearance of the quick mask.

The Masked Areas radio button displays the areas outside of the selection colored. The Selected Areas option colorizes
the areas of the selection. The Spot Color option makes the color go away completely, so better not use it.
Click on the color box to change the color of the mask overlay. The Opacity edit box lets you adjust the opacity of the
colored overlay.

2.6.5 Selection From ...
Supported by all versions of Photoshop Elements
Requirements: An image needs to be opened
This command creates a selection based on the layer mask, the vector mask, transparency of the layer (the Layer Opacity
menu item), the filter mask of a smart object, the luminosity or one of the color channels of the image.
Using the red, green or blue image channel or the luminosity as a selection can be useful for masking. If you choose one
of these options and create a layer mask, the appropriate channel will be copied into the layer mask.
Creating a selection from the layer mask can also be done by holding down the Ctrl key and clicking on the layer mask in
the Layers panel, but the other four items of the Selection From sub menu cannot be performed otherwise.
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2.7 Filter Menu

ElementsXXL adds one new menu item to the Filter menu of Photoshop Elements. Additionally, if the currently selected
layer is a smart object, ElementsXXL applies filters from the Filter menu (as well as Enhance menu) as smart filters.

2.7.1 Convert For Smart Filters
Supported by Photoshop Elements 6 and higher
Requirements: An image has to be opened.
This command converts a layer into a smart object, which is the requirement for applying filters as smart filters. The
Convert For Smart Filters command is identical to Layer > Smart Object > Convert To Smart Object, but better accessible
in case you want to apply filters as smart filters to a smart object.
Once you created a smart object you can apply smart filters either from the menu items on the Filter menu or with the
Filter > Add Smart Filter command discussed below.

2.7.2 Add Smart Filters
Supported by Photoshop Elements 6 and higher
Requirements: An image has to be opened.
The Add Smart Filters menu item lets you apply smart filters to a smart object. If the current layer is not a smart object, it
will automatically be converted into one. Alternatively you can also use the Filter > Convert For Smart Filters command for
creating a smart object and apply the smart filters by choosing a filter item on the Filter menu.

On the Add tab sheet of the appearing Smart Filters dialog you can switch between filter groups with the left list box and
choose a filter in the right list box. To apply a smart filter either click the Add button or double click a filter item in the right
list. As a result the filter dialog appears. In the case of the native filters a second Blending dialog follows. For third party
plugins you can adjust the blending on the Edit tab sheet. For more information on editing smart filters see the Layer
Menu page.
Once you are satisfied click the OK button in the bottom right corner or click Cancel to undo all operations in this dialog.
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2.7.3 Chromatic Aberration Removal
Supported by Photoshop Elements 5 and higher
Requirements: An image has to be opened.
The Chromatic Aberration Removal filter removes color fringes that are caused by lower quality lenses in the corners of
the photo.

Before you run this filter we recommend that you zoom the image to 100 - 400% and scroll one of the four image corners
into view. This way you will be able to see the chromatic aberrations and can target them better with the sliders of this
filter. Each of the three sliders removes fringes of different color. Try various slider values until the fringes are less visible
or vanish completely.

2.7.4 Supported Smart Filters
ElementsXXL is able to apply up to 103 native filters as smart filters (96 from the Filter and 7 from the Enhance menu).
Additionally up to 262 third party filters can be used as smart filters.
If you choose a filter from the Filter menu and it does not work as a smart filter, you are asked to simplify the layer, which
means removing the smart object. Some native filters, e.g. Liquify or the filters from the Filter > Adjustments sub menu, do
not support smart filtering and thus require simplification.
These filters from the Enhance menu are applied as smart filters:
Shadows/Highlights
Color Variations
Unsharp Mask
Smart Sharpen
Sharpen (only Photoshop Elements 8 and higher)
Sharpen More (only Photoshop Elements 8 and higher)
Sharpen Edges (only Photoshop Elements 8 and higher)
The following native filters from the Filter menu do not support smart filtering:
Equalize
Gradient Map
Invert
Posterize
Threshold
Photo Filter
Lens Blur
Liquify
3D Transform
Texture Fill
Comic
Graphic Novel
Pen and Ink
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Additionally, in Photoshop Elements 6 and 7 the following native filters from the Filter menu do not support smart
filtering:
Find Edges
Solarisation
Facet
Fragment
NTSC Colors
For a list of supported third-party smart filters see the Compatibility page. For more information on smart filtering see the
Smart Filter section of the Layer menu page.
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2.8 View Menu

ElementsXXL adds two menu items to the View menu of Photoshop Elements for dealing with printing and video format
issues.

2.8.1 Proof Color
Supported by all versions of Photoshop Elements
Requirements: An image has to be opened.
The Proof Color option simulates how the image looks on other devices, e.g. when printed with a certain printer or printing
method. This way you can detect and correct color problems before they actually occur. This feature basically converts
the color values from the color space of the image to the color space of the selected device when displaying the image on
your monitor screen.

The Device to Simulate combo box has the current color profile selected, which is usually sRGB, by default. To view
your image with another profile, select another item from this combo box. Best keep the Preserve RGB Numbers check
box activated unless you have some color management knowledge.
To restore the original proof settings simply select the menu item again and press OK.

2.8.2 Custom Pixel Aspect Ratio
Supported by all versions of Photoshop Elements
Requirements: An image has to be opened.
The pixel aspect ratio of the computer image is 1.0, so the width and height of a pixel are the same and form a square.
However, there are some video formats that do not use square pixels. Here are examples of such formats and their
aspect ratio:
D1/DV NTSC

0.91

D1/DV PAL

1.09

D1/DVNTSC Widescreen

1.21

HDV 1080/DVPRO HD 720

1.33

D1/DV PAL Widescreen

1.46
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DVCPRO HD 1080

1.5

Anamorphic 2:1

2.0

The Custom Pixel Aspect Ratio menu item lets you set a special pixel ratio in case you edit frames of such video files. To
restore the pixel aspect ratio simply select the menu item again and press OK.

In Photoshop the image is displayed stretched according to this ratio. Unfortunately in Photoshop Elements this setting
only seems to influence the shape of the brush tip of various tools.

2.8.3 Slice Numbers
Supported by Photoshop Elements 6 and higher
Requirements: A slice has to be created.
In the top left corner of each slice rectangle you can see the slice number and two other small icons. With this menu item
you can make them go away or reappear again. For more information about slices see the Slice Tool.

2.8.4 Clear Slices
Supported by Photoshop Elements 6 and higher
Requirements: A slice has to be created.
The Clear Slices menu item deletes all slices and you can start adding new slices from scratch if you want. Even if all
slices were removed, a slice rectangle that covers the whole image is still displayed until you close and reopen the
document or restart Photoshop Elements. For more information about slices see the Slice Tool.
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2.9 Window Menu

2.9.1 Paths
Supported by all versions of Photoshop Elements
Requirements: An image has to be opened.
Clicking this menu item displays the Path panel for creating, editing and organizing paths. A path is a vector graphic that
consists of dots that are connected by lines. A path can be used to create a selection, vector mask or shape layer and can
be transformed with the Shape Selection tool.

The Pen Tool button activates the Text On Path tool, which allows creating and editing paths in Photoshop Elements 10
and higher. In older versions of Photoshop Elements you can create a path by drawing a selection and choosing New
Path > From Shape from the panel menu. On the Tool Options bar you can switch the pen tool between the Draw and
Modify modes. With the Draw icon activated you can create or extend a path. The Modify icon displays the dots of the
path and lets you move, delete or add new dots. See also Edit > Tools > Pen Tool.
The Save button lets you save the currently selected path. The new path will appear as a new item in the list box of the
Path panel. The Delete button deletes the path that is selected in the list box.
The list box of the Path panel displays a Work Path item, which selects a path that was created but not saved yet. If you
want to create a new path with the pen tool, better activate the Work Path item to make sure that no existing path is
selected and thus modified. The list box also shows all saved path items, so that you can switch between them.
Additionally if a layer with a vector mask or a shape layer is selected in the Layers panel (in Photoshop Elements 8 and
higher), you will also see its vector mask in the list box.
Even more path features are hidden on the panel menu in the top right corner. The New item of the New Path sub menu
creates an path item on the list, which does not contain any path. Use the pen tool to create a path for this new item. If a
selection is available, you can use From Selection to create a new path from it. The same is true for the From Shape,
From Text and From Vector Mask menu items: If a shape layer, text layer or layer with a vector mask is currently
selected in the Layers panel, then each menu item creates a new path from the shape, text or vector mask.
The Deselect Path item makes sure that no path is currently selected. To select a path again click on one of the list box
items of the Paths panel. The Save Path and Delete Path commands work just like the Save and Delete buttons
mentioned above. The Duplicate Path menu item replicates the currently selected path. The Rename Path item lets you
change the name of the selected path. You can achieve the same by double clicking an item in the list box. The Make
Selection command creates a selection from the current path. As already mentioned you can also recreate a path from
the selection with the New > From Selection menu item. The Convert To Shape item produces a shape layer from the
current path after asking for a color.
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Fill Path
The Fill Path item of the panel menu fills an image layer with a color or pattern by using the current path. This operation is
similar to creating a selection and using the Edit > Fill Selection command. Before applying the Fill Path command make
sure that an image layer is selected and that no selection is present, otherwise it may not work.

The Fill Path dialog offers various parameters. You can choose a color or pattern, blending mode, opacity, feathering and
anti-alias of the filling operation.

Stroke Path
The Stroke Path item of the panel menu draws the outlines of the current path on an image layer by using a certain tool.
This operation is similar to creating a selection and using the Edit > Stroke Selection command, but much more versatile.
Before applying the Stroke Path command make sure that an image layer is selected and that no selection is present,
otherwise it may not work.

The Stroke Path dialog lets you select the tool that will be used for stroking as well as activate a Simulate Pressure
check box for more irregular stroke. The stroke is drawn according to the tool options of the selected tool. So before using
the Stroke Path command it is a good idea to select the tool that you want to use and adjust its settings on the Tool
Options bar in order to achieve the stroke you had in mind.
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Clipping Path
The Clipping Path item of the panel menu is useful if you want to save a part of the image (and not the whole image) to a
PDF file. The clipping path can only be seen in the saved PDF and not in Photoshop Elements itself.

The Clipping Path dialog lets you select the path that will be used as a clipping path and define the flatness (meaning
softness) of the path curves.
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2.10 Help Menu

2.10.1 ElementsXXL Help
(Supported by all versions of Photoshop Elements, no requirements)
Clicking this menu item displays the manual of ElementsXXL where you can inform yourself about its features.

2.10.2 ElementsXXL Videos
(Supported by all versions of Photoshop Elements, no requirements)
This menu item displays a web page with videos for ElementsXXL that show how to accomplish certain things with the
features of ElementsXXL.

2.10.3 About Plug-In > ElementsXXL
(Supported by all versions of Photoshop Elements, no requirements)
Displays the About message of ElementsXXL, which also includes its version number.
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3 Other Features
3.1 Icons, Buttons & Panel Menus
ElementsXXL adds two menu items and two sub menus to the File menu of Photoshop Elements.

3.1.1 Tool Bar Icons
Supported by Photoshop Elements 11 and higher

In Photoshop Elements 11 (and higher) two icons are added at the bottom of the tool bar below the two color boxes: the
Quick Mask icon and the Tools icon. You can click on the Quick Mask icon to start editing in Quick Mask Mode and click
again to exit this mode. If you double click it, Quick Mask Mode is activated and at the same time the Quick Mask Options
dialog is displayed. Clicking on the Tools icon displays the Tools sub menu of the Edit menu, which contains various
additional tools that are activated by ElementsXXL.

3.1.2 Control Bar Buttons
Supported by Photoshop Elements 8 and higher
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Three buttons, called Script, Actions and Render, which display a menu, are added to the control bar. In Photoshop
Elements 11 (and higher) they are located at the left hand side and in Photoshop Elements 8-10 they appear at the right
hand side of the control bar.
These buttons display the Scripts and Actions sub menu of the File menu as well as the Render sub menu of the Image
menu. They allow you to much faster access and run scripts and actions as well as process 16-bit images with smart
filters and layers. For more information on the items on these menus see the Scripts, Actions and Render sub menus.

3.1.3 Layers Panel Features
Supported by Photoshop Elements 8 and higher
Depending on the version of Photoshop Elements two or three icons are added to the top or bottom of the Layers panel.
Additionally double clicking different areas on a layer item triggers certain functions.
Here are screenshots of Photoshop Elements 11 and 8 that illustrate which features ElementsXXL adds to the Layers
panel and which areas can be clicked:
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Layer Mask Icon
ElementsXXL adds a layer mask icon to the Layers panel of Photoshop Elements 8. In Photoshop Elements 9 and higher
such an icon is already available and ElementsXXL only supplies additional functionality to it.
Clicking the layer mask icon adds a layer mask to the selected layer. If a selection is present when clicking it, the selection
is drawn into the layer mask. If a selection is present and you hold down the Ctrl key when clicking the layer mask icon,
then a vector mask is created instead of a layer mask. If you additionally hold down the Alt key, an inverted selection is
drawn into the layer mask or added as a vector mask.
See the Layer Mask and Vector Mask sub menus of the Layers menu page for more information.

Layer Style Icon
Click on the "fx" icon to display the Style Settings dialog for adding or editing layer effects. If the background is currently
selected, you will be asked to convert it into a layer before continuing.

Layer Group Icon
Clicking this icon embeds all selected layers into a layer group. If a layer group is already selected when clicking it, the
layer group is dissolved and the embedded layers are ungrouped again. You have to ungroup in order to edit the layers of
a layer group. Then you can create the layer group again. See the Group/Ungroup Layers commands of the Layers menu
for more information.
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Smart Object Icon
You can click the smart object icon to embed the selected layers into a smart object. If the selected layer is already a
smart object and you click this icon, then the Smart Filters dialog with activated Add tab sheet appears. If one or more
smart filters are already applied, then the Smart Filters dialog with activated Edit tab sheet appears.

Smart Filter Symbol
If a smart object has at least one smart filter applied, you can see a filter symbol at the right hand side of its layer item in
the Layers panel. Click it to display the Smart Filters dialog with activated the Edit tab sheet. There you can edit the smart
filters.

Adjustment Layer Icon Menu
The new adjustment layers that were added to the Layer > New Adjustment Layer sub menu by ElementsXXL are also
added to the menu of the adjustment layer icon.

Layer Thumbnails
ElementsXXL supports double clicking on the thumbnails of two types of layers in the Layer panel: adjustment layers that
were added by ElementsXXL and smart objects that have one or more smart filters applied.
Double clicking the thumbnail of an adjustment layer that was added by ElementsXXL makes a dialog with the filter
settings appear (just like it does for native adjustment layers added by Photoshop Elements itself). On this dialog you can
change the settings of the adjustment layer as described on the Layer Menu page. This is the only way to edit
ElementsXXL adjustment layers, because the "Edit Adjustment" item of the context menu does not work for them.
If you double click the thumbnail of a smart object, you can edit the content of the smart object. If the smart object has a
raw file embedded, the Adobe Camera Raw dialog shows up and you can readjust its settings. If the smart object contains
a normal image file, the contents of the smart object is opened as a new document. After editing, choose File > Save from
the menu to commit the changes to the smart object and then close the document. Read the Edit Contents menu item for
more information.

3.1.4 History Panel Menu
Supported by Photoshop Elements 8 and higher
The menu of the History panel offers a "History Options" item, which displays the History page of the ElementsXXL
Preferences dialog. These options can be used to change the behavior of the history panel. For more information see the
section about Preferences > ElementsXXL.
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3.2 Tool Mode

Supported by Photoshop Elements 6 and higher
Photoshop Elements does not allow using all tools on images with 16 bits per channel. Usually it asks you to convert the
image to 8-bit depth in order to use them. If you want to keep the image at 16-bit depth, this is usually not a solution. To
circumvent this limitation ElementsXXL offers a so-called Tool Mode that lets you use the restricted tool anyway.
Tool Mode is similar to the Render features of ElementsXXL. Both use an 8-bit document to apply effects to a 16-bit
document. Tool Mode is meant for quick and easy edits whereas the Render features require more planning but offer
more possibilities and control. For more information on the Render menu see Image > Render.
Tool Mode supports the following 29 tools:

• Magic Wand
• Spot Healing Brush (requires activated Sample All Layers check box)
• Healing Brush (requires activated Sample All Layers check box)
• Clone Stamp (requires activated Sample All Layers check box)
• Pattern Stamp
• Blur (requires activated Sample All Layers check box)
• Sharpen (requires activated Sample All Layers check box)
• Smudge (requires activated Sample All Layers check box)
• Dodge
• Burn
• Brush
• Impressionist Brush
• Paint Bucket
• Gradient
• Shape (Custom, Rectangle, Rounded Rectangle, Ellipse, Polygon, Star, Line)
• Type (Horizontal, Vertical, Horizontal Mask, Vertical Mask, Text on Selection, Text on Shape, Text on Path)
• Pencil
The Eraser, Background Erase and Magic Eraser tools can be used in Tool Mode, but you cannot trigger Tool Mode with
them.

Starting Tool Mode
When you click on a tool that is normally not usable with 16-bit images, ElementsXXL displays a message like this:

Now you can decide if you want to use Tool Mode, convert the image to 8-bit depth or not use the tool at all by clicking
Cancel. You do not need to click something on this message box. If you switch to a supported tool, the message box
vanishes again.
Please note: In Photoshop Elements 6-10 activating some tools will not display the message above for entering Tool
Mode. To use such a tool anyway click on another tools that displays the message. When you are in Tool Mode, simply
switch back to previous tool to use it.
To effectively apply some tools in Tool Mode you may have to activate the Sample All Layers check box on the Tool
Options bar. If it is necessary for a certain tool, you will see the bold note as in the screen shot above. Otherwise this note
will not be displayed. ElementsXXL cannot access the Tool Options settings, so it will display the note even if you already
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activated it.
Once you clicked the Tool Mode button ElementsXXL creates a new document called "Tool Mode". This new document
includes the original image converted from 16-bit down to 8-bit per channel plus a new layer with the name of the selected
tool. This layer will later be used to render the tool edits back to the original 16-bit image.

Working in Tool Mode
Once you are in Tool Mode you can apply the selected tool to the image. You can also use the Eraser, Background
Eraser and Magic eraser tools to undo some of your tool work.
You do not need to leave Tool Mode if you want to use another tool. Simply select the other tool and ElementsXXL will
automatically create a new layer for the new tool. When you switch back to the previous tool, the old tool layer will
automatically be selected.
In the Layers panel you can change the position of the tool layers and also adjust their opacity and blend mode. You can
also add a layer mask to a tool layer, but it is easier to use the Eraser tool instead. Better avoid other modifications to the
tool layers in the Layers panel, because they may not be rendered back to the original 16-bit document. Only tool layers
with the correct layer name will be applied back to the 16-bit document, so please do not rename tool layers, do not add
layers of your own and do not modify the background layer.

Exiting Tool Mode
Once you have finished and want to apply the changes, click the OK button on the small Exit Tool Mode window that is
displayed in the top right corner of the Photoshop Elements window.

As a result the tool layers are rendered to the original 16-bit document and the Tool Mode document is closed.
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3.3 Key Shortcuts
ElementsXXL adds up to 24 new key shortcuts to Photoshop Elements. Many of these key shortcuts are also available in
Photoshop. Here is a list of the ElementsXXL shortcuts:

Shortcut

Elements
Versions

Shift + N

All

File > New > Image from Clipboard

Ctrl + V

All

If no image is opened, it works like:
File > New > Image from Clipboard

Corresponding Menu Item

Alt + Shift + Ctrl + O

3 - 13

Alt + Shift + Ctrl + I

All

File > File Info

Shift + Ctrl + F

All

Edit > Fade

Shift + F5

All

Edit > Fill

Ctrl + 4

All

Image > Channels > RGB

Ctrl + 5

All

Image > Channels > Red

Ctrl + 6

All

Image > Channels > Green

Ctrl + 7

All

Image > Channels > Blue

Shift + Ctrl + H

3 - 13

File > Browse in Organizer

Enhance > Adjust Lighting > Shadows/Highlights

Ctrl + M

1 - 3, 5 - 13

Enhance > Adjust Lighting > Curves

Ctrl + B

3 - 13

Enhance > Adjust Color > Color Balance

Shift + Ctrl + B

6 - 13

Enhance > Black & White

Ctrl + J

1-2

Layer > Duplicate Layer

Alt + Shift + Ctrl + E

4 - 13

Layer > Stamp Visible

Ctrl + R

5 - 13

Filter > Correct Camera Distortion

Shift + Ctrl + X

11 - 13

Filter > Distort > Liquify

Alt + Ctrl + R

6 - 13

Select > Refine Edge

Shift + Ctrl + Q

All

Select > Edit in Quick Mask Mode

Ctrl + Alt + 4

All

Select > Selection From > Luminosity

Ctrl + Alt + 5

All

Select > Selection From > Red Channel

Ctrl + Alt + 6

All

Select > Selection From > Green Channel

Ctrl + Alt + 7

All

Select > Selection From > Blue Channel

Shift + Ctrl + Y

All

View > Proof Colors
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